aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2002-03-25 20:11:44 +0800
committerMichael Zucci <zucchi@src.gnome.org>2002-03-25 20:11:44 +0800
commitc6fc4e27a953c5213cff8400ec8e40f6f051e914 (patch)
tree7237e42f705cd584d36f3a2a4795a1bb16741dd3 /camel/Makefile.am
parentede63cde5882af8696c22ed546506ad877b73011 (diff)
downloadgsoc2013-evolution-c6fc4e27a953c5213cff8400ec8e40f6f051e914.tar
gsoc2013-evolution-c6fc4e27a953c5213cff8400ec8e40f6f051e914.tar.gz
gsoc2013-evolution-c6fc4e27a953c5213cff8400ec8e40f6f051e914.tar.bz2
gsoc2013-evolution-c6fc4e27a953c5213cff8400ec8e40f6f051e914.tar.lz
gsoc2013-evolution-c6fc4e27a953c5213cff8400ec8e40f6f051e914.tar.xz
gsoc2013-evolution-c6fc4e27a953c5213cff8400ec8e40f6f051e914.tar.zst
gsoc2013-evolution-c6fc4e27a953c5213cff8400ec8e40f6f051e914.zip
When we add a new name, up all of the cache limits, because we're probably
2002-03-25 Not Zed <NotZed@Ximian.com> * camel-text-index.c (text_index_add_name): When we add a new name, up all of the cache limits, because we're probably going to be adding more. (text_index_sync): Drop the cache limits back down again, we dont need them when looking words up. ** MERGE camel_index branch. * camel-text-index.[ch]: Added files i forgot to add (eep nearly lost all this work!) * camel-block-file.c (sync_nolock): Fix an infinite loop in syncing. svn path=/trunk/; revision=16242
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 5c00f8c0f4..d38787c218 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -4,7 +4,7 @@ SUBDIRS = providers tests
libcamelincludedir = $(includedir)/camel
-sbin_PROGRAMS = camel-lock-helper
+sbin_PROGRAMS = camel-lock-helper camel-index-control
lib_LTLIBRARIES = libcamel.la
noinst_LTLIBRARIES = libcamel-static.la
@@ -20,6 +20,7 @@ INCLUDES = -I.. -I$(srcdir)/.. \
libcamel_la_SOURCES = \
broken-date-parser.c \
camel-address.c \
+ camel-block-file.c \
camel-cipher-context.c \
camel-cms-context.c \
camel-data-cache.c \
@@ -39,6 +40,7 @@ libcamel_la_SOURCES = \
camel-folder.c \
camel-html-parser.c \
camel-http-stream.c \
+ camel-index.c \
camel-internet-address.c \
camel-lock.c \
camel-lock-client.c \
@@ -64,6 +66,7 @@ libcamel_la_SOURCES = \
camel-multipart.c \
camel-object.c \
camel-operation.c \
+ camel-partition-table.c \
camel-pgp-context.c \
camel-pgp-mime.c \
camel-smime-context.c \
@@ -92,6 +95,7 @@ libcamel_la_SOURCES = \
camel-stream-mem.c \
camel-stream-null.c \
camel-stream.c \
+ camel-text-index.c \
camel-tcp-stream-raw.c \
camel-tcp-stream-ssl.c \
camel-tcp-stream-openssl.c \
@@ -111,6 +115,7 @@ libcamel_la_SOURCES = \
libcamelinclude_HEADERS = \
broken-date-parser.h \
camel-address.h \
+ camel-block-file.h \
camel-charset-map.h \
camel-cipher-context.h \
camel-cms-context.h \
@@ -131,6 +136,7 @@ libcamelinclude_HEADERS = \
camel-folder-thread.h \
camel-folder.h \
camel-http-stream.h \
+ camel-index.h \
camel-internet-address.h \
camel-lock.h \
camel-lock-client.h \
@@ -156,6 +162,7 @@ libcamelinclude_HEADERS = \
camel-multipart.h \
camel-object.h \
camel-operation.h \
+ camel-partition-table.h \
camel-pgp-context.h \
camel-pgp-mime.h \
camel-smime-context.h \
@@ -183,6 +190,7 @@ libcamelinclude_HEADERS = \
camel-stream-mem.h \
camel-stream-null.h \
camel-stream.h \
+ camel-text-index.h \
camel-tcp-stream-raw.h \
camel-tcp-stream-ssl.h \
camel-tcp-stream.h \
@@ -214,6 +222,14 @@ camel_lock_helper_SOURCES = \
camel-lock.c \
camel-lock.h
+camel_index_control_SOURCES = \
+ camel-index-control.c
+
+camel_index_control_LDADD = \
+ $(libcamel_la_LIBADD) \
+ libcamel.la \
+ $(EVOLUTION_MAIL_LIBS)
+
install-exec-hook:
@if test -n "$(CAMEL_LOCK_HELPER_USER)"; then \
if test `whoami` = root ; then \