aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2001-05-30 01:08:53 +0800
committerDan Winship <danw@src.gnome.org>2001-05-30 01:08:53 +0800
commit11ea26d0e33405490795a766406d5e065b6b9234 (patch)
treebe249f7528c0a8b17cdd0890d40684f12eeb50e5 /camel/Makefile.am
parentefabbb93c9f61e583d835d1735834cc5bd0ce63c (diff)
downloadgsoc2013-evolution-11ea26d0e33405490795a766406d5e065b6b9234.tar
gsoc2013-evolution-11ea26d0e33405490795a766406d5e065b6b9234.tar.gz
gsoc2013-evolution-11ea26d0e33405490795a766406d5e065b6b9234.tar.bz2
gsoc2013-evolution-11ea26d0e33405490795a766406d5e065b6b9234.tar.lz
gsoc2013-evolution-11ea26d0e33405490795a766406d5e065b6b9234.tar.xz
gsoc2013-evolution-11ea26d0e33405490795a766406d5e065b6b9234.tar.zst
gsoc2013-evolution-11ea26d0e33405490795a766406d5e065b6b9234.zip
Code for logging and replaying offline operations.
* camel-disco-diary.c: Code for logging and replaying offline operations. * camel-disco-store.c (disco_construct): Set disco->status here (where we can base it on the session's offline status) rather than at init time. (disco_connect): If we connect online and have a non-empty diary, switch to RESYNCING mode and replay the diary to the server. (disco_get_folder, disco_get_folder_info): Add _resyncing variants. * camel-disco-folder.c (disco_sync, disco_expunge_uids, disco_append_message, disco_copy_messages_to, disco_move_messages_to): Add _resyncing variants to switches. (disco_expunge_uids, disco_append_message, disco_copy_messages_to, disco_move_messages_to): Remove #ifdef'ed out diary code: let the provider do it. (disco_append_message): Redo the append methods to no longer return the UID, since we're no longer doing the logging from here. svn path=/trunk/; revision=10040
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index ad0688f8cb..8284d35abc 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -24,6 +24,7 @@ libcamel_la_SOURCES = \
camel-cipher-context.c \
camel-data-wrapper.c \
camel-digest-folder.c \
+ camel-disco-diary.c \
camel-disco-folder.c \
camel-disco-store.c \
camel-exception.c \
@@ -104,6 +105,7 @@ libcamelinclude_HEADERS = \
camel-cipher-context.h \
camel-data-wrapper.h \
camel-digest-folder.h \
+ camel-disco-diary.h \
camel-disco-folder.h \
camel-disco-store.h \
camel-exception-list.def \