aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-04-06 11:52:39 +0800
committerDan Winship <danw@src.gnome.org>2000-04-06 11:52:39 +0800
commit2e4a5463075e387151afcdf61b74202a729944db (patch)
tree451716a6b189f11de18346a86716cbedf010f609 /camel/Makefile.am
parent080049ac37387efd71551bfdb661e15c0e1ce8ce (diff)
downloadgsoc2013-evolution-2e4a5463075e387151afcdf61b74202a729944db.tar
gsoc2013-evolution-2e4a5463075e387151afcdf61b74202a729944db.tar.gz
gsoc2013-evolution-2e4a5463075e387151afcdf61b74202a729944db.tar.bz2
gsoc2013-evolution-2e4a5463075e387151afcdf61b74202a729944db.tar.lz
gsoc2013-evolution-2e4a5463075e387151afcdf61b74202a729944db.tar.xz
gsoc2013-evolution-2e4a5463075e387151afcdf61b74202a729944db.tar.zst
gsoc2013-evolution-2e4a5463075e387151afcdf61b74202a729944db.zip
the URL RFC says the port must be numeric, so we don't want to do
* g_url_new really wanted to take a CamelException. So, rename Gurl to CamelURL, g_url_* to camel_url_* (with camel_url_new taking an exception), and url-util.[ch] to camel-url.[ch]. Also force url->port to be numeric and remove camel_service_getport. (I was confused before: the URL RFC says the port must be numeric, so we don't want to do getportbyname.) svn path=/trunk/; revision=2300
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 6e5f346b60..eefc48bd10 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -64,6 +64,7 @@ libcamel_la_SOURCES = \
camel-stream-fs.c \
camel-stream-mem.c \
camel-transport.c \
+ camel-url.c \
data-wrapper-repository.c \
gmime-base64.c \
gmime-content-field.c \
@@ -72,7 +73,6 @@ libcamel_la_SOURCES = \
hash-table-utils.c \
md5-utils.c \
string-utils.c \
- url-util.c \
$(pthread_SRC)
libcamelinclude_HEADERS = \
@@ -108,6 +108,7 @@ libcamelinclude_HEADERS = \
camel-stream-fs.h \
camel-stream-mem.h \
camel-transport.h \
+ camel-url.h \
data-wrapper-repository.h \
gmime-base64.h \
gmime-content-field.h \
@@ -116,7 +117,6 @@ libcamelinclude_HEADERS = \
hash-table-utils.h \
md5-utils.h \
string-utils.h \
- url-util.h \
camel-exception-list.def \
$(pthread_HDR)