aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-03-23 01:21:31 +0800
committerDan Winship <danw@src.gnome.org>2000-03-23 01:21:31 +0800
commit0f5f6d79199b16b0db1b7530c8835ad6a3bbe73c (patch)
treec0705435b394e1de37983bd78a88c51d9ea035c8 /camel/Makefile.am
parent1fa17b36192eab987255accbe14b3fe184fa0948 (diff)
downloadgsoc2013-evolution-0f5f6d79199b16b0db1b7530c8835ad6a3bbe73c.tar
gsoc2013-evolution-0f5f6d79199b16b0db1b7530c8835ad6a3bbe73c.tar.gz
gsoc2013-evolution-0f5f6d79199b16b0db1b7530c8835ad6a3bbe73c.tar.bz2
gsoc2013-evolution-0f5f6d79199b16b0db1b7530c8835ad6a3bbe73c.tar.lz
gsoc2013-evolution-0f5f6d79199b16b0db1b7530c8835ad6a3bbe73c.tar.xz
gsoc2013-evolution-0f5f6d79199b16b0db1b7530c8835ad6a3bbe73c.tar.zst
gsoc2013-evolution-0f5f6d79199b16b0db1b7530c8835ad6a3bbe73c.zip
New function to scan the provider dir and return a list of all providers.
* camel-provider.c (camel_provider_scan): New function to scan the provider dir and return a list of all providers. svn path=/trunk/; revision=2145
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 59fb9d1788..aaac035bee 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -3,13 +3,14 @@
SUBDIRS = providers
libcamelincludedir = $(includedir)/camel
-
+providerdir = $(libdir)/evolution/camel-providers/$(VERSION)
lib_LTLIBRARIES = libcamel.la
INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
-I$(top_srcdir)/intl \
- $(GTK_INCLUDEDIR)
+ $(GTK_INCLUDEDIR) \
+ -DCAMEL_PROVIDERDIR=\""$(providerdir)"\"
if ENABLE_THREADS