aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2001-06-18 22:36:44 +0800
committerMichael Zucci <zucchi@src.gnome.org>2001-06-18 22:36:44 +0800
commite905364beee184b99637029de7151b43339b2e1c (patch)
tree70761b71502abd250930cedeacc6fa191dac2bff /camel/Makefile.am
parent5255cb6d496630adb35934b850d8b064c3121c74 (diff)
downloadgsoc2013-evolution-e905364beee184b99637029de7151b43339b2e1c.tar
gsoc2013-evolution-e905364beee184b99637029de7151b43339b2e1c.tar.gz
gsoc2013-evolution-e905364beee184b99637029de7151b43339b2e1c.tar.bz2
gsoc2013-evolution-e905364beee184b99637029de7151b43339b2e1c.tar.lz
gsoc2013-evolution-e905364beee184b99637029de7151b43339b2e1c.tar.xz
gsoc2013-evolution-e905364beee184b99637029de7151b43339b2e1c.tar.zst
gsoc2013-evolution-e905364beee184b99637029de7151b43339b2e1c.zip
Only create a missing uid if we have indexing turned on.
2001-06-18 Not Zed <NotZed@Ximian.com> * camel-folder-summary.c (camel_folder_summary_info_new_from_parser): Only create a missing uid if we have indexing turned on. * camel-lock-helper.c (setup_process): Function to setup process/sanity/security checks. Change to the real uid as soon as we can. (lock_path): First try to lock as the real uid, if that fails, try the root uid. (unlock_id): Unlock as the uid we created the lock as. * Makefile.am (INCLUDES): Added -DCAMEL_SBINDIR for lock helper location. * providers/local/camel-spool-folder.c (spool_lock): Implemented, using lock helper locking. Need to work out if the locking requires a root created lock? (spool_unlock): Likewise. 2001-06-15 Not Zed <NotZed@Ximian.com> * camel-lock-helper.c: Setuid Lock helper process. Creates and manages .locks, keeping them active, removing them, etc. What real perms it needs is a little system dependent. 2001-06-14 Not Zed <NotZed@Ximian.com> * providers/local/camel-maildir-store.c (get_folder_info): Implement. (scan_dir): Does the work of scanning for maildir directories. 2001-06-13 Not Zed <NotZed@Ximian.com> * providers/local/camel-spool-store.c (get_folder_info): Implemented, just returns a hardcoded INBOX folder. (free_folder_info): implemented, free's the 1 possible level of folder info. * providers/local/camel-spool-folder.c (camel_spool_folder_construct): Set the real unread message count on the folder_created thing. svn path=/trunk/; revision=10261
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index c3a964b991..4636447f57 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -5,6 +5,8 @@ SUBDIRS = providers tests
libcamelincludedir = $(includedir)/camel
providerdir = $(libdir)/evolution/camel-providers/$(VERSION)
+sbin_PROGRAMS = camel-lock-helper
+
lib_LTLIBRARIES = libcamel.la
INCLUDES = -I.. -I$(srcdir)/.. \
@@ -15,6 +17,7 @@ INCLUDES = -I.. -I$(srcdir)/.. \
$(NSPR_CFLAGS) \
$(NSS_CFLAGS) \
$(OPENSSL_CFLAGS) \
+ -DCAMEL_SBINDIR=\""$(sbindir)"\" \
-DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
-DG_LOG_DOMAIN=\"camel\"
@@ -38,6 +41,7 @@ libcamel_la_SOURCES = \
camel-folder.c \
camel-internet-address.c \
camel-lock.c \
+ camel-lock-client.c \
camel-medium.c \
camel-mime-filter-bestenc.c \
camel-mime-filter-basic.c \
@@ -121,6 +125,7 @@ libcamelinclude_HEADERS = \
camel-folder.h \
camel-internet-address.h \
camel-lock.h \
+ camel-lock-client.h \
camel-medium.h \
camel-mime-filter-bestenc.h \
camel-mime-filter-basic.h \
@@ -191,13 +196,23 @@ libcamel_la_LIBADD = $(top_builddir)/e-util/libeutil.la \
$(OPENSSL_LDFLAGS)
+camel-lock-helper: camel-lock-helper.o camel-lock.o
+ $(CC) -o $@ $^ -I$(srcdir)/.. -I$(srcdir)
+
+install-exec-local:
+ -file=$(DESTDIR)$(sbindir)/camel-lock-helper; \
+ chown root $$file && chgrp root $$file && chmod u+s $$file
+
noinst_HEADERS = \
camel-charset-map-private.h \
camel-private.h \
- camel-search-private.h
+ camel-search-private.h \
+ camel-lock-helper.h
+# manually include camel-lock-helper.c since we build it manually
EXTRA_DIST = \
- README
+ README \
+ camel-lock-helper.c
#noinst_PROGRAMS = \
# camel-mime-filter-from