aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2001-03-15 05:59:40 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2001-03-15 05:59:40 +0800
commit174adfa471581f0a322b4e381d9671b2b50ac9d4 (patch)
treed3cbf73426097bb481593a6b8c3b7e0c4b1e32b3 /camel/Makefile.am
parent4391d0f3b1d03097f8e4fffd24857e54f8ea1eec (diff)
downloadgsoc2013-evolution-174adfa471581f0a322b4e381d9671b2b50ac9d4.tar
gsoc2013-evolution-174adfa471581f0a322b4e381d9671b2b50ac9d4.tar.gz
gsoc2013-evolution-174adfa471581f0a322b4e381d9671b2b50ac9d4.tar.bz2
gsoc2013-evolution-174adfa471581f0a322b4e381d9671b2b50ac9d4.tar.lz
gsoc2013-evolution-174adfa471581f0a322b4e381d9671b2b50ac9d4.tar.xz
gsoc2013-evolution-174adfa471581f0a322b4e381d9671b2b50ac9d4.tar.zst
gsoc2013-evolution-174adfa471581f0a322b4e381d9671b2b50ac9d4.zip
Numerous fixes to get it to build correctly with NSS enabled.
2001-03-14 Jeffrey Stedfast <fejj@ximian.com> * camel-tcp-stream-ssl.c: Numerous fixes to get it to build correctly with NSS enabled. * camel-remote-store.c (remote_connect): Pass in the session and expected host args, oops. * camel-provider.h (CAMEL_URL_ALLOW_SSL): Defined. * providers/imap/camel-imap-store.c (camel_imap_store_init): Check to see if we are supposed to use SSL and set the options accordingly. (imap_connect): Return FALSE here instead of NULL. * providers/imap/camel-imap-provider.c: Add CAMEL_URL_ALLOW_SSL. * providers/imap/libcamelimap.urls: Add "imaps" which is the protocol for Secure IMAP. svn path=/trunk/; revision=8711
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index cd544eb019..8c77f7fad6 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -14,6 +14,8 @@ INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
$(GNOME_XML_CFLAGS) \
$(UNICODE_CFLAGS) \
$(KRB4_CFLAGS) \
+ $(NSPR_CFLAGS) \
+ $(NSS_CFLAGS) \
-DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
-DG_LOG_DOMAIN=\"camel\"
@@ -158,7 +160,9 @@ libcamel_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
libcamel_la_LIBADD = $(top_builddir)/e-util/libeutil.la \
$(UNICODE_LIBS) \
- $(KRB4_LDFLAGS)
+ $(KRB4_LDFLAGS) \
+ $(NSPR_LDFLAGS) \
+ $(NSS_LDFLAGS)
noinst_HEADERS = \