aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorJon Trowbridge <trow@ximian.com>2001-12-10 11:50:36 +0800
committerJon Trowbridge <trow@src.gnome.org>2001-12-10 11:50:36 +0800
commitb5e7713c8e99f2cddf309d3034108c18190fd3cb (patch)
treeb6b22ff8bdbb379e0e4e939c09df54a8dd52c447 /camel/Makefile.am
parent098db6b2ad41196ee43d68e7f4f7d879d97d93b7 (diff)
downloadgsoc2013-evolution-b5e7713c8e99f2cddf309d3034108c18190fd3cb.tar
gsoc2013-evolution-b5e7713c8e99f2cddf309d3034108c18190fd3cb.tar.gz
gsoc2013-evolution-b5e7713c8e99f2cddf309d3034108c18190fd3cb.tar.bz2
gsoc2013-evolution-b5e7713c8e99f2cddf309d3034108c18190fd3cb.tar.lz
gsoc2013-evolution-b5e7713c8e99f2cddf309d3034108c18190fd3cb.tar.xz
gsoc2013-evolution-b5e7713c8e99f2cddf309d3034108c18190fd3cb.tar.zst
gsoc2013-evolution-b5e7713c8e99f2cddf309d3034108c18190fd3cb.zip
Implements marking messages as "Need Reply".
Implements marking messages as "Need Reply". 2001-12-09 Jon Trowbridge <trow@ximian.com> * mail-need-reply.xpm: Added a really, really ugly and awful icon to symbolize "message needs a reply". * Makefile.am (EXTRA_DIST): Added mail-need-reply.xpm. 2001-12-09 Jon Trowbridge <trow@ximian.com> * camel-folder-summary.c: Add "NeedsReply" to the flag_names array for CAMEL_MESSAGE_NEEDS_REPLY. * camel-folder-summary.h: Added CAMEL_MESSAGE_NEEDS_REPLY flag. 2001-12-09 Jon Trowbridge <trow@ximian.com> * vfoldertypes.xml: Add "Needs Reply" option to different status types. * filtertypes.xml: Add "Needs Reply" option to different status types. 2001-12-09 Jon Trowbridge <trow@ximian.com> * message-list.c: #include "art/mail-need-reply.xpm". (ml_tree_value_at): Adjust magic numbers, show "Need Reply" icon if the message needs reply. (message_list_create_extras): Adjust magic numbers to add new icon. (on_click): Changed to toggle between unread, read, and need reply when the status icon is clicked. * mail-callbacks.c (mark_as_needing_reply): Added. (mark_as_not_needing_reply): Added. Add "set" value to struct post_send_data. (composer_sent_cb): Use both "flags" and "set" elements of post_send_data when setting message flags. (mail_reply): Clear "Needs Reply" flag when we actually reply to a message. * folder-browser.c: Changed flag values to be given by bit-shifting (1<<5) vs. base-ten (32). Added CAN_MARK_DOESNT_NEED_REPLY flag. Added "Mark as Needing Reply" and "Mark as Not Needing Reply" elements to context menu. (on_right_click): Hide "Mark as (Not) Needing Reply" context menu elements as appropriate. svn path=/trunk/; revision=14946
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 0fad241d6a..1ea31d5add 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -18,7 +18,6 @@ INCLUDES = -I.. -I$(srcdir)/.. \
$(KRB4_CFLAGS) \
$(NSPR_CFLAGS) \
$(NSS_CFLAGS) \
- $(OPENSSL_CFLAGS) \
-DCAMEL_SBINDIR=\""$(sbindir)"\" \
-DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
-DG_LOG_DOMAIN=\"camel\"
@@ -201,8 +200,7 @@ libcamel_la_LIBADD = $(top_builddir)/e-util/libeutil.la \
$(CAMEL_LIBS) \
$(KRB4_LDFLAGS) \
$(NSPR_LDFLAGS) \
- $(NSS_LDFLAGS) \
- $(OPENSSL_LDFLAGS)
+ $(NSS_LDFLAGS)
libcamel_static_la_SOURCES = $(libcamel_la_SOURCES)
libcamel_static_la_LIBADD = $(libcamel_la_LIBADD)