aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2002-02-08 09:56:45 +0800
committerDan Winship <danw@src.gnome.org>2002-02-08 09:56:45 +0800
commit92d7dbf6cea9dc43bd55e353c9b38315791a6317 (patch)
tree60118f9982e4b084d7e14ae74cfa76c0f155f962 /camel/Makefile.am
parente02a62282c0227dc50938cff9dbe28be8fed1cab (diff)
downloadgsoc2013-evolution-92d7dbf6cea9dc43bd55e353c9b38315791a6317.tar
gsoc2013-evolution-92d7dbf6cea9dc43bd55e353c9b38315791a6317.tar.gz
gsoc2013-evolution-92d7dbf6cea9dc43bd55e353c9b38315791a6317.tar.bz2
gsoc2013-evolution-92d7dbf6cea9dc43bd55e353c9b38315791a6317.tar.lz
gsoc2013-evolution-92d7dbf6cea9dc43bd55e353c9b38315791a6317.tar.xz
gsoc2013-evolution-92d7dbf6cea9dc43bd55e353c9b38315791a6317.tar.zst
gsoc2013-evolution-92d7dbf6cea9dc43bd55e353c9b38315791a6317.zip
Implementation of NTLM (aka "Secure Password Authentication") auth, taken
* camel-sasl-ntlm.c: Implementation of NTLM (aka "Secure Password Authentication") auth, taken from soup. * Makefile.am (libcamel_la_SOURCES, libcamel_la_HEADERS): Add camel-sasl-ntlm. * camel-sasl.c: Add refs to camel-sasl-ntlm. * providers/imap/camel-imap-store.c (try_auth): Use imap_next_word() to skip over the "+ " of the continuation rather than just "resp + 2" since Exchange (incorrectly) returns "+" instead of "+ " for an empty continuation response. svn path=/trunk/; revision=15605
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 95b45f07e7..4e626c45ea 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -74,6 +74,7 @@ libcamel_la_SOURCES = \
camel-sasl-digest-md5.c \
camel-sasl-kerberos4.c \
camel-sasl-login.c \
+ camel-sasl-ntlm.c \
camel-sasl-plain.c \
camel-sasl-popb4smtp.c \
camel-search-private.c \
@@ -163,6 +164,7 @@ libcamelinclude_HEADERS = \
camel-sasl-digest-md5.h \
camel-sasl-kerberos4.h \
camel-sasl-login.h \
+ camel-sasl-ntlm.h \
camel-sasl-plain.h \
camel-sasl-popb4smtp.h \
camel-seekable-stream.h \