aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2002-02-28 07:45:28 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2002-02-28 07:45:28 +0800
commite83a759e4ea8eec0615f8306cacacd620702dc2f (patch)
treebe33277fa2fe2c1369dc385b3ab23c73dd0ebc2e /camel/Makefile.am
parent9cf2e390356256917fe31ae544e39dfc35a879ce (diff)
downloadgsoc2013-evolution-e83a759e4ea8eec0615f8306cacacd620702dc2f.tar
gsoc2013-evolution-e83a759e4ea8eec0615f8306cacacd620702dc2f.tar.gz
gsoc2013-evolution-e83a759e4ea8eec0615f8306cacacd620702dc2f.tar.bz2
gsoc2013-evolution-e83a759e4ea8eec0615f8306cacacd620702dc2f.tar.lz
gsoc2013-evolution-e83a759e4ea8eec0615f8306cacacd620702dc2f.tar.xz
gsoc2013-evolution-e83a759e4ea8eec0615f8306cacacd620702dc2f.tar.zst
gsoc2013-evolution-e83a759e4ea8eec0615f8306cacacd620702dc2f.zip
New stream filter that chomps excess trailing whitespace from the end of
2002-02-27 Jeffrey Stedfast <fejj@ximian.com> * camel-mime-filter-chomp.c (camel_mime_filter_chomp_new): New stream filter that chomps excess trailing whitespace from the end of the stream. This is needed to update the PGP/MIME code to comply with rfc3156. * camel-pgp-mime.c (camel_pgp_mime_part_verify): Don't attach a from filter, if it ain't from-filtered already, then we'll just be breaking stuff. To become rfc3156 compliant, add a chomp filter here. (camel_pgp_mime_part_sign): Add a chomp filter here too. svn path=/trunk/; revision=15863
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 4e626c45ea..a59d75f496 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -45,6 +45,7 @@ libcamel_la_SOURCES = \
camel-mime-filter-bestenc.c \
camel-mime-filter-basic.c \
camel-mime-filter-charset.c \
+ camel-mime-filter-chomp.c \
camel-mime-filter-crlf.c \
camel-mime-filter-from.c \
camel-mime-filter-html.c \
@@ -135,6 +136,7 @@ libcamelinclude_HEADERS = \
camel-mime-filter-bestenc.h \
camel-mime-filter-basic.h \
camel-mime-filter-charset.h \
+ camel-mime-filter-chomp.h \
camel-mime-filter-crlf.h \
camel-mime-filter-from.h \
camel-mime-filter-html.h \