aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:08:56 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:08:56 +0800
commit5a2fc93d303f227d3f6fe80f4561b6fc37fd220f (patch)
treef6049932bb5d0dece5bc148e15730e8be4ad1861 /camel/Makefile.am
parentbc61f8e11ccdb24c8a5ad4efafb31cfb097733fe (diff)
downloadgsoc2013-evolution-5a2fc93d303f227d3f6fe80f4561b6fc37fd220f.tar
gsoc2013-evolution-5a2fc93d303f227d3f6fe80f4561b6fc37fd220f.tar.gz
gsoc2013-evolution-5a2fc93d303f227d3f6fe80f4561b6fc37fd220f.tar.bz2
gsoc2013-evolution-5a2fc93d303f227d3f6fe80f4561b6fc37fd220f.tar.lz
gsoc2013-evolution-5a2fc93d303f227d3f6fe80f4561b6fc37fd220f.tar.xz
gsoc2013-evolution-5a2fc93d303f227d3f6fe80f4561b6fc37fd220f.tar.zst
gsoc2013-evolution-5a2fc93d303f227d3f6fe80f4561b6fc37fd220f.zip
Update to the new $(BASE_VERSION)-versioned path. Likewise. Likewise.
* providers/imap/Makefile.am (libcamelimapincludedir): Update to the new $(BASE_VERSION)-versioned path. * providers/smtp/Makefile.am (libcamelsmtpincludedir): Likewise. * providers/sendmail/Makefile.am (libcamelsendmailincludedir): Likewise. * providers/pop3/Makefile.am (libcamelpop3includedir): Likewise. * providers/nntp/Makefile.am (libcamelnntpincludedir): Likewise. * providers/local/Makefile.am (libcamellocalincludedir): Likewise. * camel-lock-client.c (camel_lock_helper_init): Use CAMEL_LIBEXECDIR instead of CAMEL_SBINDIR to find camel-lock-helper. * Makefile.am: Install camel-lock-helper and camel-index-control in $(libexec)/evolution/$(BASE_VERSION)/camel. Install libcamel.la in $privlibdir. (install-exec-hook): Update for the new location of camel-lock-helper. (libcamelincludedir): Version using $(BASE_VERSION). (INCLUDES): Define CAMEL_LIBEXECDIR. svn path=/trunk/; revision=19554
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 0e76d2a1b1..9dc4a2f723 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -2,17 +2,18 @@
SUBDIRS = . providers tests
-libcamelincludedir = $(includedir)/camel
+libcamelincludedir = $(includedir)/evolution-$(BASE_VERSION)/camel
-sbin_PROGRAMS = camel-lock-helper camel-index-control
+camellibexecdir = $(libexec)/evolution/$(BASE_VERSION)/camel/
+camellibexec_PROGRAMS = camel-lock-helper camel-index-control
-lib_LTLIBRARIES = libcamel.la
+privlib_LTLIBRARIES = libcamel.la
noinst_LTLIBRARIES = libcamel-static.la
INCLUDES = -I.. -I$(srcdir)/.. \
-I$(top_srcdir)/intl \
-I$(top_srcdir)/e-util \
- -DCAMEL_SBINDIR=\""$(sbindir)"\" \
+ -DCAMEL_LIBEXECDIR=\""$(camellibexecdir)"\" \
-DCAMEL_PROVIDERDIR=\""$(camel_providerdir)"\" \
-DG_LOG_DOMAIN=\"camel\" \
-DG_DISABLE_DEPRECATED \
@@ -252,8 +253,8 @@ camel_index_control_LDADD = \
install-exec-hook:
@if test -n "$(CAMEL_LOCK_HELPER_USER)"; then \
if test `whoami` = root ; then \
- chown $(CAMEL_LOCK_HELPER_USER) $(DESTDIR)$(sbindir)/camel-lock-helper ; \
- chmod u+s $(DESTDIR)$(sbindir)/camel-lock-helper ; \
+ chown $(CAMEL_LOCK_HELPER_USER) $(DESTDIR)$(camellibexecdir)/camel-lock-helper ; \
+ chmod u+s $(DESTDIR)$(camellibexecdir)/camel-lock-helper ; \
else \
echo '*** WARNING ***' ; \
echo "Camel will not be able to open mbox files until you perform the following steps:" ; \
@@ -267,14 +268,14 @@ install-exec-hook:
fi
@if test -n "$(CAMEL_LOCK_HELPER_GROUP)"; then \
if test `whoami` = root ; then \
- chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(sbindir)/camel-lock-helper ; \
- chmod g+s $(DESTDIR)$(sbindir)/camel-lock-helper ; \
+ chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(camellibexecdir)/camel-lock-helper ; \
+ chmod g+s $(DESTDIR)$(camellibexecdir)/camel-lock-helper ; \
else \
echo '*** WARNING ***' ; \
echo "Camel will not be able to open mbox files until you perform the following steps:" ; \
echo " 1. Become root" ; \
- echo " 2. chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(sbindir)/camel-lock-helper" ; \
- echo " 3. chmod g+s $(DESTDIR)$(sbindir)/camel-lock-helper" ; \
+ echo " 2. chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(camellibexecdir)/camel-lock-helper" ; \
+ echo " 3. chmod g+s $(DESTDIR)$(camellibexecdir)/camel-lock-helper" ; \
echo '*** WARNING ***' ; \
fi \
else \