aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorPeter Williams <peterw@ximian.com>2001-06-29 04:35:43 +0800
committerPeter Williams <peterw@src.gnome.org>2001-06-29 04:35:43 +0800
commit6ffa930086b903dbd8fed3543f5e4ed762b6e8d1 (patch)
tree805bc825e07162f42996776921d770efe44b4b69 /camel/Makefile.am
parentdacae0532fb39cee00b4f8ccfa8157d3a31b3a80 (diff)
downloadgsoc2013-evolution-6ffa930086b903dbd8fed3543f5e4ed762b6e8d1.tar
gsoc2013-evolution-6ffa930086b903dbd8fed3543f5e4ed762b6e8d1.tar.gz
gsoc2013-evolution-6ffa930086b903dbd8fed3543f5e4ed762b6e8d1.tar.bz2
gsoc2013-evolution-6ffa930086b903dbd8fed3543f5e4ed762b6e8d1.tar.lz
gsoc2013-evolution-6ffa930086b903dbd8fed3543f5e4ed762b6e8d1.tar.xz
gsoc2013-evolution-6ffa930086b903dbd8fed3543f5e4ed762b6e8d1.tar.zst
gsoc2013-evolution-6ffa930086b903dbd8fed3543f5e4ed762b6e8d1.zip
Add a CamelMimeFilterStripHeader that removes a header from mime output. Used
by sendmail to strip the BCC from the email while still sending to the BCC recipients. camel: 2001-06-28 Peter Williams <peterw@ximian.com> * camel-mime-filter-stripheader.c: New file. Filter that strips a header from mime output. * camel-mime-filter-stripheader.h: New file. Header for the above. * providers/smtp/camel-smtp-transport.c (smtp_data): Use the stripheader filter to remove the "Bcc" header. * Makefile.am: Add the stripheader files. * tests/lib/Makefile.am (INCLUDES): Get this to compile again. * tests/mime-filter/test-stripheader.c: New file. Test suite for the CamelMimeFilterStripHeader. * tests/mime-filter/Makefile.am: New test section: mime filters. mail: 2001-06-28 Peter Williams <peterw@ximian.com> * mail-ops.c (mail_send_message): Revert fejj's Bcc header removal; this unsets the BCC recipients and so doesn't send to the Bcc'd people at all. svn path=/trunk/; revision=10576
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 4c2d34261a..e8e0253efb 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -52,6 +52,7 @@ libcamel_la_SOURCES = \
camel-mime-filter-index.c \
camel-mime-filter-linewrap.c \
camel-mime-filter-save.c \
+ camel-mime-filter-stripheader.c \
camel-mime-filter.c \
camel-mime-message.c \
camel-mime-parser.c \
@@ -136,6 +137,7 @@ libcamelinclude_HEADERS = \
camel-mime-filter-index.h \
camel-mime-filter-linewrap.h \
camel-mime-filter-save.h \
+ camel-mime-filter-stripheader.h \
camel-mime-filter.h \
camel-mime-message.h \
camel-mime-parser.h \