aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorPeter Williams <peterw@ximian.com>2001-07-14 01:35:51 +0800
committerPeter Williams <peterw@src.gnome.org>2001-07-14 01:35:51 +0800
commit54e037a91cf1de9d82f87675e1bf857d90763f4d (patch)
tree65a5f80979106de683a0ae5b712060eae5c4d1ec /camel/Makefile.am
parentfd982262e8f6b1ce2002641bce8e46e324e60296 (diff)
downloadgsoc2013-evolution-54e037a91cf1de9d82f87675e1bf857d90763f4d.tar
gsoc2013-evolution-54e037a91cf1de9d82f87675e1bf857d90763f4d.tar.gz
gsoc2013-evolution-54e037a91cf1de9d82f87675e1bf857d90763f4d.tar.bz2
gsoc2013-evolution-54e037a91cf1de9d82f87675e1bf857d90763f4d.tar.lz
gsoc2013-evolution-54e037a91cf1de9d82f87675e1bf857d90763f4d.tar.xz
gsoc2013-evolution-54e037a91cf1de9d82f87675e1bf857d90763f4d.tar.zst
gsoc2013-evolution-54e037a91cf1de9d82f87675e1bf857d90763f4d.zip
Let people install as non-root, but give them a bigass warning so they're
2001-07-13 Peter Williams <peterw@ximian.com> * Makefile.am (install-exec-local): Let people install as non-root, but give them a bigass warning so they're not allowed to complain when it doesn't work right. * camel-remote-store.c (sync_remote_folder): New function: hash table callback. (remote_disconnect): If cleanly disconnecting, sync our folders. Fixes deadlocks on exit (folders syncing after store disconnects) and also makes sense. svn path=/trunk/; revision=11090
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am26
1 files changed, 22 insertions, 4 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 408a0e33d0..7dafb8bf83 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -204,13 +204,31 @@ camel-lock-helper: camel-lock-helper.o camel-lock.o
if CAMEL_LOCK_HELPER_SETUID
install-exec-local:
- chown $(CAMEL_LOCK_HELPER_USER) $(DESTDIR)$(sbindir)/camel-lock-helper
- chmod u+s $(DESTDIR)$(sbindir)/camel-lock-helper
+ @if test `whoami` = root ; then \
+ chown $(CAMEL_LOCK_HELPER_USER) $(DESTDIR)$(sbindir)/camel-lock-helper ; \
+ chmod u+s $(DESTDIR)$(sbindir)/camel-lock-helper ; \
+ else \
+ echo '*** WARNING ***' ; \
+ echo "Camel will not be able to open mbox files until you perform the following steps:" ; \
+ echo " 1. Become root" ; \
+ echo " 2. chown $(CAMEL_LOCK_HELPER_USER) $(DESTDIR)$(sbindir)/camel-lock-helper" ; \
+ echo " 3. chmod u+s $(DESTDIR)$(sbindir)/camel-lock-helper" ; \
+ echo '*** WARNING ***' ; \
+ fi
endif
if CAMEL_LOCK_HELPER_SETGID
install-exec-local:
- chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(sbindir)/camel-lock-helper
- chmod g+s $(DESTDIR)$(sbindir)/camel-lock-helper
+ @if test `whoami` = root ; then \
+ chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(sbindir)/camel-lock-helper ; \
+ chmod g+s $(DESTDIR)$(sbindir)/camel-lock-helper ; \
+ else \
+ echo '*** WARNING ***' ; \
+ echo "Camel will not be able to open mbox files until you perform the following steps:" ; \
+ echo " 1. Become root" ; \
+ echo " 2. chgrp $(CAMEL_LOCK_HELPER_GROUP) $(DESTDIR)$(sbindir)/camel-lock-helper" ; \
+ echo " 3. chmod g+s $(DESTDIR)$(sbindir)/camel-lock-helper" ; \
+ echo '*** WARNING ***' ; \
+ fi
endif