aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorbertrand <Bertrand.Guiheneuf@aful.org>2000-02-15 06:03:58 +0800
committerBertrand Guiheneuf <bertrand@src.gnome.org>2000-02-15 06:03:58 +0800
commitfe058b1be72112298e356343f3a8b35fd60a072b (patch)
tree0e2fe60abb27fa6070dc20f1e427b002c6db6f5a /camel/Makefile.am
parentd8efd64ed0bc53ad0a74115c1d14a700b3874013 (diff)
downloadgsoc2013-evolution-fe058b1be72112298e356343f3a8b35fd60a072b.tar
gsoc2013-evolution-fe058b1be72112298e356343f3a8b35fd60a072b.tar.gz
gsoc2013-evolution-fe058b1be72112298e356343f3a8b35fd60a072b.tar.bz2
gsoc2013-evolution-fe058b1be72112298e356343f3a8b35fd60a072b.tar.lz
gsoc2013-evolution-fe058b1be72112298e356343f3a8b35fd60a072b.tar.xz
gsoc2013-evolution-fe058b1be72112298e356343f3a8b35fd60a072b.tar.zst
gsoc2013-evolution-fe058b1be72112298e356343f3a8b35fd60a072b.zip
make a blocking version of the header parser. When the fs stream uses
2000-02-14 bertrand <Bertrand.Guiheneuf@aful.org> * camel/gmime-utils.c (get_header_array_from_stream): make a blocking version of the header parser. When the fs stream uses gnome-vfs, this should be changed. (gmime_read_line_from_stream): ditto. 2000-02-11 bertrand <Bertrand.Guiheneuf@aful.org> * camel/camel-stream-fs.c: everywhere, when using the cur_pos field, do it on the CamelSeekableStream object. (_seek): small fix. * camel/camel-seekable-stream.c (camel_seekable_stream_seek): s/camel_stream_seek/camel_seekable_stream_seek/g * camel/camel-seekable-stream.h: (struct ): added a field to store the current position. * camel/camel-seekable-stream.c (camel_seekable_stream_get_current_position): New function. Allows to get the current position of a seekable stream. In fact much more changes, but I am lazy. This is the begining of some major changes in camel. svn path=/trunk/; revision=1778
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 2db0ecf42c..cff67fc736 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -53,6 +53,7 @@ libcamel_la_SOURCES = \
camel-provider.c \
camel-recipient.c \
camel-seekable-stream.c \
+ camel-seekable-substream.c \
camel-service.c \
camel-session.c \
camel-store.c \
@@ -94,6 +95,7 @@ libcamelinclude_HEADERS = \
camel-provider.h \
camel-recipient.h \
camel-seekable-stream.h \
+ camel-seekable-substream.h \
camel-service.h \
camel-session.h \
camel-store.h \