aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2001-05-08 04:33:25 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2001-05-08 04:33:25 +0800
commit416d8fa6cd84e6b25886c1c2fcbf2b0dbce58b7f (patch)
treeed169f150b00a9edcd0c03ba642f166a62919d21 /camel/Makefile.am
parentfe36d75cf353522bc31362bd9b8800470fa511b3 (diff)
downloadgsoc2013-evolution-416d8fa6cd84e6b25886c1c2fcbf2b0dbce58b7f.tar
gsoc2013-evolution-416d8fa6cd84e6b25886c1c2fcbf2b0dbce58b7f.tar.gz
gsoc2013-evolution-416d8fa6cd84e6b25886c1c2fcbf2b0dbce58b7f.tar.bz2
gsoc2013-evolution-416d8fa6cd84e6b25886c1c2fcbf2b0dbce58b7f.tar.lz
gsoc2013-evolution-416d8fa6cd84e6b25886c1c2fcbf2b0dbce58b7f.tar.xz
gsoc2013-evolution-416d8fa6cd84e6b25886c1c2fcbf2b0dbce58b7f.tar.zst
gsoc2013-evolution-416d8fa6cd84e6b25886c1c2fcbf2b0dbce58b7f.zip
Add support for using OpenSSL.
2001-05-04 Jeffrey Stedfast <fejj@ximian.com> * providers/smtp/camel-smtp-transport.c (connect_to_server): Add support for using OpenSSL. * camel-remote-store.c (remote_connect): Add support for using the OpenSSL implementation. * camel-tcp-stream-ssl.c (ssl_bad_cert): Hmmmm, don't pass in a NULL as the last argument to alert_user - prototype doesn't take that argument anymore? * camel-tcp-stream-openssl.c (camel_tcp_stream_openssl_finalize): (ssl_verify): Use a global hash table to try and lookup the CamelTcpStreamOpenSSL object given the ssl context since OpenSSL doesn't think one needs to pass data around, we should all be living in a world of global variables, duh! svn path=/trunk/; revision=9697
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index cf6a0b48e3..dda2cb13f0 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -15,6 +15,7 @@ INCLUDES = -I.. -I$(srcdir)/.. \
$(KRB4_CFLAGS) \
$(NSPR_CFLAGS) \
$(NSS_CFLAGS) \
+ $(OPENSSL_CFLAGS) \
-DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
-DG_LOG_DOMAIN=\"camel\"
@@ -179,7 +180,8 @@ libcamel_la_LIBADD = $(top_builddir)/e-util/libeutil.la \
$(GAL_LIBS) \
$(KRB4_LDFLAGS) \
$(NSPR_LDFLAGS) \
- $(NSS_LDFLAGS)
+ $(NSS_LDFLAGS) \
+ $(OPENSSL_LDFLAGS)
noinst_HEADERS = \