aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2001-02-08 09:42:53 +0800
committerMichael Zucci <zucchi@src.gnome.org>2001-02-08 09:42:53 +0800
commit49f8a687a41e635cd83807d33c74afe8e55fb3df (patch)
tree4162f19a2db18ff787386c7c97a98e5e8a5e7744 /camel/Makefile.am
parent1290da3f286a31745b1814610c16918c2e84e140 (diff)
downloadgsoc2013-evolution-49f8a687a41e635cd83807d33c74afe8e55fb3df.tar
gsoc2013-evolution-49f8a687a41e635cd83807d33c74afe8e55fb3df.tar.gz
gsoc2013-evolution-49f8a687a41e635cd83807d33c74afe8e55fb3df.tar.bz2
gsoc2013-evolution-49f8a687a41e635cd83807d33c74afe8e55fb3df.tar.lz
gsoc2013-evolution-49f8a687a41e635cd83807d33c74afe8e55fb3df.tar.xz
gsoc2013-evolution-49f8a687a41e635cd83807d33c74afe8e55fb3df.tar.zst
gsoc2013-evolution-49f8a687a41e635cd83807d33c74afe8e55fb3df.zip
Changed to push the operation into a status stack.
2001-02-07 Not Zed <NotZed@Ximian.com> * camel-operation.c (camel_operation_start): Changed to push the operation into a status stack. (camel_operation_progress): Changed to only accept % complete. (camel_operation_reset): Free status stack as well. * providers/pop3/camel-pop3-folder.c (pop3_get_message): Get the octect count from the return line, and pass it to get_additional_data(). (pop3_refresh_info): Added status stuff. * providers/pop3/camel-pop3-store.c (camel_pop3_command_get_additional_data): Added a total bytes expected argument for progress reporting & fixed callers. (camel_pop3_command_get_additional_data): Added progress reporting. * providers/local/camel-mbox-summary.c (mbox_summary_sync_full): (mbox_summary_sync_quick): (summary_rebuild): Added progress reporting stuff. svn path=/trunk/; revision=8095
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 063ec03f08..55d28f48fc 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -46,6 +46,7 @@ libcamel_la_SOURCES = \
camel-movemail.c \
camel-multipart.c \
camel-object.c \
+ camel-operation.c \
camel-provider.c \
camel-remote-store.c \
camel-search-private.c \
@@ -102,6 +103,7 @@ libcamelinclude_HEADERS = \
camel-movemail.h \
camel-multipart.h \
camel-object.h \
+ camel-operation.h \
camel-provider.h \
camel-remote-store.h \
camel-seekable-stream.h \