aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/pcs/Makefile.am
diff options
context:
space:
mode:
authorRodrigo Moya <rodrigo@ximian.com>2001-06-22 21:08:02 +0800
committerRodrigo Moya <rodrigo@src.gnome.org>2001-06-22 21:08:02 +0800
commita7846c7d6d408bf9acdb04353f0b9097745eb277 (patch)
tree9d4d33aea6123e5e203eaa42b371e95312eae363 /calendar/pcs/Makefile.am
parent997e2b35630e4d290ce67b125cd94f118cc83892 (diff)
downloadgsoc2013-evolution-a7846c7d6d408bf9acdb04353f0b9097745eb277.tar
gsoc2013-evolution-a7846c7d6d408bf9acdb04353f0b9097745eb277.tar.gz
gsoc2013-evolution-a7846c7d6d408bf9acdb04353f0b9097745eb277.tar.bz2
gsoc2013-evolution-a7846c7d6d408bf9acdb04353f0b9097745eb277.tar.lz
gsoc2013-evolution-a7846c7d6d408bf9acdb04353f0b9097745eb277.tar.xz
gsoc2013-evolution-a7846c7d6d408bf9acdb04353f0b9097745eb277.tar.zst
gsoc2013-evolution-a7846c7d6d408bf9acdb04353f0b9097745eb277.zip
changed getFreeBusy method to return a CalObj instead of a sequence
2001-06-22 Rodrigo Moya <rodrigo@ximian.com> * idl/evolution-calendar.idl: changed getFreeBusy method to return a CalObj instead of a sequence * cal-client/cal-client.[ch] (cal_client_get_free_busy): changed it to work like the cal_client_get_object function, that is, it does not return anymore a list of UIDs, but a CalClientGetStatus code, and added a new parameter for the caller to get the component back when this function returns (cal_client_open): aggregate WombatClient interface to the CalListener being used * pcs/cal-backend-db.c, pcs/cal-backend-file.c (..get_free_busy): set return value to "char *" as it will be returning a FreeBusy object, and not a list of UIDs * pcs/cal-backend.[ch] (cal_backend_get_free_busy): ditto * pcs/cal.c (cal_construct): queryInterface on the listener to obtain the WombatClient interface svn path=/trunk/; revision=10393
Diffstat (limited to 'calendar/pcs/Makefile.am')
-rw-r--r--calendar/pcs/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/calendar/pcs/Makefile.am b/calendar/pcs/Makefile.am
index 227ca53257..9806c13fb3 100644
--- a/calendar/pcs/Makefile.am
+++ b/calendar/pcs/Makefile.am
@@ -4,6 +4,8 @@ INCLUDES = \
-I$(top_srcdir)/calendar \
-I$(top_srcdir)/libical/src/libical \
-I$(top_builddir)/libical/src/libical \
+ -I$(top_srcdir)/libwombat \
+ -I$(top_builddir)/libwombat \
$(BONOBO_VFS_GNOME_CFLAGS) \
$(EXTRA_GNOME_CFLAGS) \
-DGNOMELOCALEDIR=\""$(localedir)"\"