aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/pcs/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-03-04 11:58:38 +0800
committerSeth Alves <alves@src.gnome.org>2000-03-04 11:58:38 +0800
commitc6c65136bb37bd87e9d50735e1543bd296ee513d (patch)
treebae8f8cc3283a1dd94b2fa11ed1352e66acdd067 /calendar/pcs/Makefile.am
parent7f1494e3f4b335c61b579c0568538ec83e6d30ee (diff)
downloadgsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.gz
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.bz2
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.lz
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.xz
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.tar.zst
gsoc2013-evolution-c6c65136bb37bd87e9d50735e1543bd296ee513d.zip
new file -- things shared between the client and server go in this
* cal-util/Makefile.am: new file -- things shared between the client and server go in this directory * calobj.c calobj.h icalendar.c icalendar.h timeutil.c timeutil.h cal-util.c cal-util.h where moved backend stuff went into pcs. shared stuff went into cal-util. svn path=/trunk/; revision=2032
Diffstat (limited to 'calendar/pcs/Makefile.am')
-rw-r--r--calendar/pcs/Makefile.am52
1 files changed, 35 insertions, 17 deletions
diff --git a/calendar/pcs/Makefile.am b/calendar/pcs/Makefile.am
index dd9e3302b9..69f718b4a4 100644
--- a/calendar/pcs/Makefile.am
+++ b/calendar/pcs/Makefile.am
@@ -4,6 +4,23 @@
bin_PROGRAMS = tlacuache
+#INCLUDES = \
+# -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+# -I$(top_srcdir)/libical/src/libical \
+# -I$(top_srcdir)/libversit \
+# -I$(top_srcdir)/calendar \
+# -I. \
+# -I$(top_srcdir)/calendar/cal-client \
+# $(GNOME_INCLUDEDIR)
+
+INCLUDES = \
+ -I$(top_srcdir)/calendar/cal-client \
+ -I$(top_srcdir)/calendar/cal-util \
+ -I$(top_srcdir)/calendar \
+ -I$(top_srcdir)/libical/src/libical \
+ $(GNOME_INCLUDEDIR) \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\"
+
CORBA_GENERATED = \
evolution-calendar.h \
evolution-calendar-common.c \
@@ -18,19 +35,17 @@ idl_flags = `$(GNOME_CONFIG) --cflags idl`
$(CORBA_GENERATED): $(idls)
$(ORBIT_IDL) $(idl_flags) $(srcdir)/../idl/evolution-calendar.idl
-tlacuache_INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
- -I$(srcdir) -I$(top_srcdir) \
- -I. \
- -I.. \
- -I$(top_builddir) \
- -I$(includedir) \
- $(GNOME_INCLUDEDIR)
+#tlacuache_INCLUDES = \
+# -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+# -I$(srcdir) -I$(top_srcdir) \
+# -I. \
+# -I.. \
+# -I$(top_builddir) \
+# -I$(includedir) \
+# $(GNOME_INCLUDEDIR)
tlacuache_SOURCES = \
$(CORBA_GENERATED) \
- alarm.c \
- alarm.h \
cal.c \
cal.h \
cal-backend.c \
@@ -38,23 +53,26 @@ tlacuache_SOURCES = \
cal-common.h \
cal-factory.c \
cal-factory.h \
- cal-util.c \
- cal-util.h \
calobj.c \
calobj.h \
icalendar.c \
icalendar.h \
job.c \
job.h \
- timeutil.c \
- timeutil.h \
tlacuache.c
+# alarm.c \
+# alarm.h \
+# cal-util.c \
+# cal-util.h \
+
+
ICAL_LINK_FLAGS = $(top_builddir)/libical/src/libical/libical.la
-tlacuache_LDADD = \
- $(BONOBO_VFS_GNOME_LIBS) \
- ../libversit/libversit.la \
+tlacuache_LDADD = \
+ $(BONOBO_VFS_GNOME_LIBS) \
+ $(top_srcdir)/calendar/cal-util/libcalutil.la \
+ $(top_srcdir)/libversit/libversit.la \
$(ICAL_LINK_FLAGS)
gnorbadir = $(sysconfdir)/CORBA/servers