aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/pcs/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-04-25 04:01:44 +0800
committerSeth Alves <alves@src.gnome.org>2000-04-25 04:01:44 +0800
commit33f48d299ea754aa6679a092ad820e8c96a020f6 (patch)
tree64c0bb75a340a59ed485bf13761149ced216f8da /calendar/pcs/Makefile.am
parentd38dcd1631a6017598a78f7cc82a48b50753a911 (diff)
downloadgsoc2013-evolution-33f48d299ea754aa6679a092ad820e8c96a020f6.tar
gsoc2013-evolution-33f48d299ea754aa6679a092ad820e8c96a020f6.tar.gz
gsoc2013-evolution-33f48d299ea754aa6679a092ad820e8c96a020f6.tar.bz2
gsoc2013-evolution-33f48d299ea754aa6679a092ad820e8c96a020f6.tar.lz
gsoc2013-evolution-33f48d299ea754aa6679a092ad820e8c96a020f6.tar.xz
gsoc2013-evolution-33f48d299ea754aa6679a092ad820e8c96a020f6.tar.zst
gsoc2013-evolution-33f48d299ea754aa6679a092ad820e8c96a020f6.zip
allow for null CN (parse_person): allow for null sent_by
* pcs/icalendar.c (parse_person): allow for null CN (parse_person): allow for null sent_by * pcs/Makefile.am: build icalendar-test * pcs/icalendar-test.c: a test which loads an ical file and converts it to our internal format, and then saves it back out. svn path=/trunk/; revision=2588
Diffstat (limited to 'calendar/pcs/Makefile.am')
-rw-r--r--calendar/pcs/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/calendar/pcs/Makefile.am b/calendar/pcs/Makefile.am
index 545e403201..11aba079cb 100644
--- a/calendar/pcs/Makefile.am
+++ b/calendar/pcs/Makefile.am
@@ -38,5 +38,24 @@ libpcs_a_SOURCES = \
job.c \
job.h
+
+
+noinst_PROGRAMS = icalendar-test
+
+icalendar_test_SOURCES = \
+ icalendar-test.c \
+ icalendar.c \
+ icalendar-save.c
+
+icalendar_test_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/libical/src/libical/libical.la
+
+# $(top_builddir)/calendar/cal-util/libcal-util.la \
+
+
+
+
BUILT_SOURCES = $(CORBA_GENERATED)
CLEANFILES += $(BUILT_SOURCES)