aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/pcs/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-04-17 03:25:56 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-04-17 03:25:56 +0800
commit75f8b00ea05e5485530fb4a74af7e9afdf5345ae (patch)
treeb74f223155112d6ae34b554183a500a6e801b7f2 /calendar/pcs/Makefile.am
parent98a15f353372d37e48f5c925c91aa2f40cbb942a (diff)
downloadgsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.gz
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.bz2
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.lz
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.xz
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.zst
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.zip
Renamed library from libcalutil to libcal-util, to be consistent with
2000-04-16 Federico Mena Quintero <federico@helixcode.com> * cal-util/Makefile.am: Renamed library from libcalutil to libcal-util, to be consistent with libcal-client. Install header files in $(includedir)/evolution/cal-util. (INCLUDES): Add "cal-util" log domain for glib. (libcal_clientincludedir): The header files are now installed in $(includedir)/evolution/cal-client. * cal-util/cal-util.h: Fix includes. * cal-client/client-test.c: Fix includes. * pcs/Makefile.am: Create libpcs.a, not a shared library, because it is for internal use by Wombat only. The header files should not be installed, either. Removed all the old Tlacuache stuff. * gui/Makefile.am (EXTRA_DIST): We no longer distribute gncal.desktop. (evolution_calendar_INCLUDES): Add "calendar-gui" for the glib log domain. * gui/*.[ch]: Fix cal-util and cal-client includes. * pcs/Makefile.am (INCLUDES): Added "pcs" log domain for glib. * pcs/*.[ch]: Fix cal-util includes. svn path=/trunk/; revision=2461
Diffstat (limited to 'calendar/pcs/Makefile.am')
-rw-r--r--calendar/pcs/Makefile.am82
1 files changed, 9 insertions, 73 deletions
diff --git a/calendar/pcs/Makefile.am b/calendar/pcs/Makefile.am
index a567597975..a13df5b990 100644
--- a/calendar/pcs/Makefile.am
+++ b/calendar/pcs/Makefile.am
@@ -1,26 +1,9 @@
-#
-# Tlacuache personal calendar server
-#
-
-bin_PROGRAMS = tlacuache
-lib_LTLIBRARIES = libpcs.la
-
-#INCLUDES = \
-# -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
-# -I$(top_srcdir)/libical/src/libical \
-# -I$(top_srcdir)/libversit \
-# -I$(top_srcdir)/calendar \
-# -I. \
-# -I$(top_srcdir)/calendar/cal-client \
-# $(GNOME_INCLUDEDIR)
-
-INCLUDES = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/calendar/cal-client \
- -I$(top_srcdir)/calendar/cal-util \
- -I$(top_srcdir)/calendar \
- -I$(top_srcdir)/libical/src/libical \
- $(GNOME_INCLUDEDIR) \
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"pcs\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/calendar \
+ -I$(top_srcdir)/libical/src/libical \
+ $(GNOME_INCLUDEDIR) \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
CORBA_GENERATED = \
@@ -37,16 +20,9 @@ idl_flags = `$(GNOME_CONFIG) --cflags idl`
$(CORBA_GENERATED): $(idls)
$(ORBIT_IDL) $(idl_flags) $(srcdir)/../idl/evolution-calendar.idl
-#tlacuache_INCLUDES = \
-# -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
-# -I$(srcdir) -I$(top_srcdir) \
-# -I. \
-# -I.. \
-# -I$(top_builddir) \
-# -I$(includedir) \
-# $(GNOME_INCLUDEDIR)
+noinst_LIBRARIES = libpcs.a
-tlacuache_SOURCES = \
+libpcs_a_SOURCES = \
$(CORBA_GENERATED) \
cal.c \
cal.h \
@@ -58,44 +34,4 @@ tlacuache_SOURCES = \
icalendar.c \
icalendar.h \
job.c \
- job.h \
- tlacuache.c
-
-# alarm.c \
-# alarm.h \
-# cal-util.c \
-# cal-util.h \
-
-libpcs_la_SOURCES = \
- $(CORBA_GENERATED) \
- cal.c \
- cal-backend.c \
- cal-factory.c \
- icalendar.c \
- job.c
-
-libpcsincludedir = $(includedir)/calendar/pcs
-
-libpcsinclude_HEADERS = \
- cal.h \
- cal-backend.h \
- cal-common.h \
- cal-factory.h \
- icalendar.h \
- job.h
-
-ICAL_LINK_FLAGS = $(top_builddir)/libical/src/libical/libical.la
-
-tlacuache_LDADD = \
- $(BONOBO_VFS_GNOME_LIBS) \
- $(top_builddir)/calendar/cal-util/libcalutil.la \
- $(top_builddir)/libversit/libversit.la \
- $(ICAL_LINK_FLAGS)
-
-gnorbadir = $(sysconfdir)/CORBA/servers
-
-gnorba_DATA = \
- tlacuache.gnorba
-
-EXTRA_DIST = \
- $(gnorba_DATA)
+ job.h