aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/pcs/Makefile.am
diff options
context:
space:
mode:
authorPeter Williams <peterw@ximian.com>2002-07-18 05:03:19 +0800
committerPeter Williams <peterw@src.gnome.org>2002-07-18 05:03:19 +0800
commit515ebfd45c748cf31e2f45fe9180f97e08051498 (patch)
treed4df60220d5b044b3c084dadbd8d023bae1b4422 /calendar/pcs/Makefile.am
parent6485e5fcf75cd73418204e444418925134e3bdab (diff)
downloadgsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.gz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.bz2
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.lz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.xz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.zst
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.zip
Install libversit.a so that people compiling against the addressbook can
2002-07-09 Peter Williams <peterw@ximian.com> * libversit/Makefile.am (privlib_LIBRARIES): Install libversit.a so that people compiling against the addressbook can do so successfully. * Makefile.am: create our *Conf.sh files and dist them and install them. * configure.in: Define and subst some variables that the Conf.sh file need. 2002-07-08 Peter Williams <peterw@ximian.com> * backend/ebook/Makefile.am: Install libebook-static.la. Also change --all-static to -all-static, which is the right flag. * backend/pas/Makefile.am: Install the PAS headers in $(includedir)/evolution/pas. Install libpas.a 2002-07-08 Peter Williams <peterw@ximian.com> * cal-util/Makefile.am: Install libcal-util-static.la and fix the -all-static flag to make it install statically. * pcs/Makefile.am: Install libpcs.a and its headers. * pcs/cal-backend-util.h: Same sort of include namespacing fix, but for pcs. * pcs/cal.h: * pcs/query.h: * pcs/cal-factory.h: * pcs/cal-backend.h: * pcs/cal-backend-file.h: Same. 2002-07-17 Peter Williams <peterw@ximian.com> * calendar/cal-util/Makefile.am (GTKDOC_LIBS): Because we're using libtool as our LD, we can reference .la's and libtool will DTRT for us. * calendar/cal-client/Makefile.am (GTKDOC_LIBS): Same here. 2002-07-03 Peter Williams <peterw@ximian.com> * Makefile.am: Install libeutil, libeconduit, and libedb3util and their headers. 2002-07-08 Peter Williams <peterw@ximian.com> * Makefile.am: Reference the new libefilterbar.a. 2002-07-12 Peter Williams <peterw@ximian.com> * Makefile.am (INCLUDES): Add -I$(builddir)/libical/src/libical for the generated ical.h (some headers rely on this because they too get installed.) 2002-07-09 Peter Williams <peterw@ximian.com> * e-timezone-dialog/Makefile.am: Add -I$(top_builddir)/libical/src/libical; some headers that we rely on get installed, so they point to the ical.h that gets generated and installed; consequently we need to be able to find the generated ical.h * misc/Makefile.am: Install libemiscwidgets.a and its headers. However, break EFilterBar into a separate libefilterbar.a because we don't want the installed library to depend on libfilter. svn path=/trunk/; revision=17496
Diffstat (limited to 'calendar/pcs/Makefile.am')
-rw-r--r--calendar/pcs/Makefile.am34
1 files changed, 22 insertions, 12 deletions
diff --git a/calendar/pcs/Makefile.am b/calendar/pcs/Makefile.am
index 57c24d3130..0c9800bd4d 100644
--- a/calendar/pcs/Makefile.am
+++ b/calendar/pcs/Makefile.am
@@ -2,6 +2,7 @@ INCLUDES = \
-DG_LOG_DOMAIN=\"wombat-pcs\" \
-I$(top_srcdir) \
-I$(top_srcdir)/calendar \
+ -I$(top_builddir)/calendar \
-I$(top_srcdir)/libical/src/libical \
-I$(top_builddir)/libical/src/libical \
-I$(top_srcdir)/libwombat \
@@ -9,12 +10,16 @@ INCLUDES = \
-DGNOMELOCALEDIR=\""$(localedir)"\" \
$(EVOLUTION_CALENDAR_CFLAGS)
-CORBA_GENERATED = \
- evolution-calendar.h \
+CORBA_GENERATED_H = \
+ evolution-calendar.h
+
+CORBA_GENERATED_C = \
evolution-calendar-common.c \
evolution-calendar-skels.c \
evolution-calendar-stubs.c
+CORBA_GENERATED = $(CORBA_GENERATED_H) $(CORBA_GENERATED_C)
+
idls = \
$(srcdir)/../idl/evolution-calendar.idl
@@ -23,26 +28,31 @@ idl_flags = -I $(srcdir) `$(GNOME_CONFIG) --cflags idl` -I $(datadir)/idl
$(CORBA_GENERATED): $(idls)
$(ORBIT_IDL) $(idl_flags) $(srcdir)/../idl/evolution-calendar.idl
-noinst_LIBRARIES = libpcs.a
+pcsincludedir = $(includedir)/evolution/pcs
-libpcs_a_SOURCES = \
- $(CORBA_GENERATED) \
- cal.c \
+privlib_LIBRARIES = libpcs.a
+
+pcsinclude_HEADERS = \
+ $(CORBA_GENERATED_H) \
cal.h \
- cal-backend.c \
cal-backend.h \
- cal-backend-file.c \
cal-backend-file.h \
- cal-backend-util.c \
cal-backend-util.h \
cal-common.h \
- cal-factory.c \
cal-factory.h \
- job.c \
job.h \
- query.c \
query.h
+libpcs_a_SOURCES = \
+ $(pcsinclude_HEADERS) \
+ $(CORBA_GENERATED_C) \
+ cal.c \
+ cal-backend.c \
+ cal-backend-file.c \
+ cal-backend-util.c \
+ cal-factory.c \
+ job.c \
+ query.c
BUILT_SOURCES = $(CORBA_GENERATED)
CLEANFILES = $(BUILT_SOURCES)