aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/pcs/Makefile.am
diff options
context:
space:
mode:
authorHans Petter Jansson <hpj@ximian.com>2003-11-01 02:03:20 +0800
committerHans Petter <hansp@src.gnome.org>2003-11-01 02:03:20 +0800
commitdd09d630872427be423ac416340192a24e2d037e (patch)
treeee2a40b507516d82d5615ae04280d81604508354 /calendar/pcs/Makefile.am
parenta7ac69cdc61b193cbc62fbe908652cebf1ee8f2d (diff)
downloadgsoc2013-evolution-dd09d630872427be423ac416340192a24e2d037e.tar
gsoc2013-evolution-dd09d630872427be423ac416340192a24e2d037e.tar.gz
gsoc2013-evolution-dd09d630872427be423ac416340192a24e2d037e.tar.bz2
gsoc2013-evolution-dd09d630872427be423ac416340192a24e2d037e.tar.lz
gsoc2013-evolution-dd09d630872427be423ac416340192a24e2d037e.tar.xz
gsoc2013-evolution-dd09d630872427be423ac416340192a24e2d037e.tar.zst
gsoc2013-evolution-dd09d630872427be423ac416340192a24e2d037e.zip
Add the webcal source group.
2003-10-31 Hans Petter Jansson <hpj@ximian.com> * gui/calendar-component.c (calendar_component_init): Add the webcal source group. * gui/dialogs/new-calendar.c (print_uri_noproto): Implement. (group_is_remote): Implement. (create_new_source_with_group): Implement webcal case. (new_calendar_dialog): Get optional location from dialog. * gui/dialogs/new-calendar.glade: Add location entry. * pcs/Makefile.am: Build http backend. * pcs/cal-backend-http.[ch]: Add skeleton based on cal-backend-file. svn path=/trunk/; revision=23153
Diffstat (limited to 'calendar/pcs/Makefile.am')
-rw-r--r--calendar/pcs/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/calendar/pcs/Makefile.am b/calendar/pcs/Makefile.am
index 921ac896d6..0e47694cee 100644
--- a/calendar/pcs/Makefile.am
+++ b/calendar/pcs/Makefile.am
@@ -38,7 +38,7 @@ $(CORBA_GENERATED_C): $(CORBA_GENERATED_H)
pcsincludedir = $(privincludedir)/pcs
privlib_LTLIBRARIES = libpcs.la
-noinst_LTLIBRARIES = libpcsfile.la
+noinst_LTLIBRARIES = libpcsfile.la libpcshttp.la
pcsinclude_HEADERS = \
$(CORBA_GENERATED_H) \
@@ -77,6 +77,13 @@ libpcsfile_la_SOURCES = \
libpcsfile_la_LIBADD = \
libpcs.la
+libpcshttp_la_SOURCES = \
+ cal-backend-http.c \
+ cal-backend-http.h
+
+libpcshttp_la_LIBADD = \
+ libpcs.la
+
BUILT_SOURCES = $(CORBA_GENERATED)
CLEANFILES = $(BUILT_SOURCES)