aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/importers/Makefile.am
diff options
context:
space:
mode:
authorDamon Chaplin <damon@ximian.com>2002-02-09 09:03:32 +0800
committerDamon Chaplin <damon@src.gnome.org>2002-02-09 09:03:32 +0800
commitbf5ad102a4af562b220c3f68360031294cf1e758 (patch)
treeabd7a9b00d8265bc3dcdb79015a887d80185d164 /calendar/importers/Makefile.am
parent3c81b8f46ccc17cd5e8fe7dd453d99cca756c7f1 (diff)
downloadgsoc2013-evolution-bf5ad102a4af562b220c3f68360031294cf1e758.tar
gsoc2013-evolution-bf5ad102a4af562b220c3f68360031294cf1e758.tar.gz
gsoc2013-evolution-bf5ad102a4af562b220c3f68360031294cf1e758.tar.bz2
gsoc2013-evolution-bf5ad102a4af562b220c3f68360031294cf1e758.tar.lz
gsoc2013-evolution-bf5ad102a4af562b220c3f68360031294cf1e758.tar.xz
gsoc2013-evolution-bf5ad102a4af562b220c3f68360031294cf1e758.tar.zst
gsoc2013-evolution-bf5ad102a4af562b220c3f68360031294cf1e758.zip
added vCalendar importer and intelligent GnomeCalendar importer code here,
2002-02-08 Damon Chaplin <damon@ximian.com> * importers/icalendar-importer.c: added vCalendar importer and intelligent GnomeCalendar importer code here, as it shares a lot of code with the iCalendar importer. NOTE: check_folder_type() needs to be finished at some point. It needs a new shell Corba call so it can decide whether to import events or tasks into the folder. Currently it just imports both. * importers/main.c (importer_factory_fn): create vCalendar importer or GnomeCalendar importer if required. * importers/evolution-calendar-importer.h: added declarations for creating a vCalendar importer and intelligent Gnome Calendar importer. * importers/Makefile.am: added -DEVOLUTION_SOUNDDIR so the importer knows what filename to use for audio alarms in vCalendar files. Added libicalvcal-evolution to LDADD. * importers/GNOME_Evolution_Calendar_Importer.oaf.in: added vCalendar importer and intelligent Gnome Calendar importer. * gui/comp-util.c (cal_comp_util_compare_event_timezones): return TRUE if the event uses UTC. We don't want to flag all events from Outlook, which use UTC. svn path=/trunk/; revision=15628
Diffstat (limited to 'calendar/importers/Makefile.am')
-rw-r--r--calendar/importers/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/calendar/importers/Makefile.am b/calendar/importers/Makefile.am
index 4734bb687a..4015e12f86 100644
--- a/calendar/importers/Makefile.am
+++ b/calendar/importers/Makefile.am
@@ -1,7 +1,10 @@
bin_PROGRAMS = evolution-calendar-importer
+sounddir = $(datadir)/evolution/sounds
+
INCLUDES = \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_SOUNDDIR=\""$(sounddir)"\" \
-DG_LOG_DOMAIN=\"Evolution-Importer\" \
-I$(top_srcdir) \
-I$(top_builddir)/shell \
@@ -12,6 +15,7 @@ INCLUDES = \
-I$(top_builddir)/calendar \
-I$(top_srcdir)/libical/src/libical \
-I$(top_builddir)/libical/src/libical \
+ -I$(top_srcdir)/libical/src/libicalvcal \
$(EVOLUTION_CALENDAR_CFLAGS)
evolution_calendar_importer_SOURCES = \
@@ -25,6 +29,7 @@ evolution_calendar_importer_LDADD = \
$(top_builddir)/calendar/cal-client/libcal-client.la \
$(top_builddir)/libwombat/libwombat.la \
$(top_builddir)/libical/src/libical/libical-evolution.la \
+ $(top_builddir)/libical/src/libicalvcal/libicalvcal-evolution.la \
$(EVOLUTION_CALENDAR_LIBS)
oafdir = $(datadir)/oaf