aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/dialogs/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
committerMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
commit8692b1cb72654888f0dab31843bdf05d3ac2a888 (patch)
tree3e172e8085830cf0770cf0a7ab04bd714753d3a9 /calendar/gui/dialogs/Makefile.am
parent399b1a6fc593a9c5e692923120346e0386f578e5 (diff)
downloadgsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.gz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.bz2
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.lz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.xz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.zst
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.zip
Add an --enable-code-coverage configure option to enable gcov support
When enabled, this will compile all libraries/binaries with the necessary gcc and ld flags to enable code coverage support using gcov.
Diffstat (limited to 'calendar/gui/dialogs/Makefile.am')
-rw-r--r--calendar/gui/dialogs/Makefile.am33
1 files changed, 18 insertions, 15 deletions
diff --git a/calendar/gui/dialogs/Makefile.am b/calendar/gui/dialogs/Makefile.am
index 42e6730103..9c7b3053a2 100644
--- a/calendar/gui/dialogs/Makefile.am
+++ b/calendar/gui/dialogs/Makefile.am
@@ -1,20 +1,21 @@
noinst_LTLIBRARIES = libcal-dialogs.la
-libcal_dialogs_la_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- -DG_LOG_DOMAIN=\"calendar-gui\" \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- -I$(top_srcdir)/calendar \
- -I$(top_builddir)/shell \
- -I$(top_srcdir)/shell \
- -DEVOLUTION_UIDIR=\""$(uidir)"\" \
- -DEVOLUTION_ICONDIR=\""$(icondir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
- -DPREFIX=\""$(prefix)"\" \
- $(EVOLUTION_DATA_SERVER_CFLAGS) \
- $(GNOME_PLATFORM_CFLAGS) \
- $(GTKHTML_CFLAGS)
+libcal_dialogs_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -DG_LOG_DOMAIN=\"calendar-gui\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/calendar \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ -DEVOLUTION_UIDIR=\""$(uidir)"\" \
+ -DEVOLUTION_ICONDIR=\""$(icondir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(CODE_COVERAGE_CFLAGS)
ecalendarincludedir = $(privincludedir)/calendar/gui/dialogs
@@ -45,6 +46,8 @@ ecalendarinclude_HEADERS = \
task-editor.h \
task-page.h
+libcal_dialogs_la_LDFLAGS = $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
+
libcal_dialogs_la_LIBADD = \
$(top_builddir)/addressbook/util/libeabutil.la \
$(EVOLUTION_DATA_SERVER_LIBS) \