aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/dialogs/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2001-07-13 01:56:50 +0800
committerJP Rosevear <jpr@src.gnome.org>2001-07-13 01:56:50 +0800
commit469e9372d6a2a0b6f99f64a99c5a690ff0a6ec54 (patch)
treecd1fec1e95e01ce2f2dfd69ced163847d1066e04 /calendar/gui/dialogs/Makefile.am
parentb0dabea18bc7102021d4df05da97540da9eb3c16 (diff)
downloadgsoc2013-evolution-469e9372d6a2a0b6f99f64a99c5a690ff0a6ec54.tar
gsoc2013-evolution-469e9372d6a2a0b6f99f64a99c5a690ff0a6ec54.tar.gz
gsoc2013-evolution-469e9372d6a2a0b6f99f64a99c5a690ff0a6ec54.tar.bz2
gsoc2013-evolution-469e9372d6a2a0b6f99f64a99c5a690ff0a6ec54.tar.lz
gsoc2013-evolution-469e9372d6a2a0b6f99f64a99c5a690ff0a6ec54.tar.xz
gsoc2013-evolution-469e9372d6a2a0b6f99f64a99c5a690ff0a6ec54.tar.zst
gsoc2013-evolution-469e9372d6a2a0b6f99f64a99c5a690ff0a6ec54.zip
fix typo breaking compilation
2001-07-12 JP Rosevear <jpr@ximian.com> * gui/e-calendar-table.c (e_calendar_table_copy_clipboard): fix typo breaking compilation * gui/dialogs/meeting-page.c: fix include * gui/dialogs/Makefile.am: build select names idl here * gui/Makefile.am: remove select names compilation from here svn path=/trunk/; revision=11050
Diffstat (limited to 'calendar/gui/dialogs/Makefile.am')
-rw-r--r--calendar/gui/dialogs/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/calendar/gui/dialogs/Makefile.am b/calendar/gui/dialogs/Makefile.am
index bb0778162b..f9c95f3341 100644
--- a/calendar/gui/dialogs/Makefile.am
+++ b/calendar/gui/dialogs/Makefile.am
@@ -1,4 +1,19 @@
-gladedir = $(datadir)/evolution/glade
+## CORBA stuff
+
+IDLS = \
+ $(top_srcdir)/addressbook/gui/component/select-names/Evolution-Addressbook-SelectNames.idl
+
+IDL_GENERATED = \
+ Evolution-Addressbook-SelectNames.h \
+ Evolution-Addressbook-SelectNames-common.c \
+ Evolution-Addressbook-SelectNames-skels.c \
+ Evolution-Addressbook-SelectNames-stubs.c
+
+$(IDL_GENERATED): $(IDLS)
+ $(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
+ $(top_srcdir)/addressbook/gui/component/select-names/Evolution-Addressbook-SelectNames.idl
+
+BUILT_SOURCES = $(IDL_GENERATED)
INCLUDES = \
-DG_LOG_DOMAIN=\"calendar-gui\" \
@@ -21,6 +36,7 @@ INCLUDES = \
noinst_LIBRARIES = libcal-dialogs.a
libcal_dialogs_a_SOURCES = \
+ $(IDL_GENERATED) \
alarm-options.c \
alarm-options.h \
alarm-page.c \
@@ -60,6 +76,7 @@ libcal_dialogs_a_SOURCES = \
task-page.c \
task-page.h
+gladedir = $(datadir)/evolution/glade
glade_DATA = \
alarm-options.glade \
alarm-page.glade \
@@ -74,6 +91,11 @@ glade_DATA = \
etspecdir = $(datadir)/evolution/etspec/
etspec_DATA = meeting-page.etspec
+CLEANFILES += $(BUILT_SOURCES)
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+
EXTRA_DIST = \
$(glade_DATA) \
$(etspec_DATA)