aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/alarm-notify/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-06 09:58:11 +0800
committerDan Winship <danw@src.gnome.org>2003-02-06 09:58:11 +0800
commit0494cd37730ddca4932352cdee09d702a546ca55 (patch)
tree66215fdec38c81d216ee4508ceb8669c7d79e485 /calendar/gui/alarm-notify/Makefile.am
parent84d3e4130f8d54b616c2f097db3e451b2635c707 (diff)
downloadgsoc2013-evolution-0494cd37730ddca4932352cdee09d702a546ca55.tar
gsoc2013-evolution-0494cd37730ddca4932352cdee09d702a546ca55.tar.gz
gsoc2013-evolution-0494cd37730ddca4932352cdee09d702a546ca55.tar.bz2
gsoc2013-evolution-0494cd37730ddca4932352cdee09d702a546ca55.tar.lz
gsoc2013-evolution-0494cd37730ddca4932352cdee09d702a546ca55.tar.xz
gsoc2013-evolution-0494cd37730ddca4932352cdee09d702a546ca55.tar.zst
gsoc2013-evolution-0494cd37730ddca4932352cdee09d702a546ca55.zip
Use privlibexecdir. (INCLUDES): Remove cruft. (gladedir, serversdir):
* gui/alarm-notify/Makefile.am: Use privlibexecdir. (INCLUDES): Remove cruft. (gladedir, serversdir): Remove definitions (evolution_alarm_notify_LDFLAGS): Remove no-longer-needed -export-dynamic. * gui/alarm-notify/alarm-notify-dialog.c (write_html_heading): s/ICONSDIR/IMAGESDIR * gui/alarm-notify/notify-main.c (main): Fix up gettext initialization svn path=/trunk/; revision=19793
Diffstat (limited to 'calendar/gui/alarm-notify/Makefile.am')
-rw-r--r--calendar/gui/alarm-notify/Makefile.am20
1 files changed, 6 insertions, 14 deletions
diff --git a/calendar/gui/alarm-notify/Makefile.am b/calendar/gui/alarm-notify/Makefile.am
index d53a2360c5..4766db866a 100644
--- a/calendar/gui/alarm-notify/Makefile.am
+++ b/calendar/gui/alarm-notify/Makefile.am
@@ -11,8 +11,7 @@ idl_flags = $(IDL_INCLUDES)
$(CORBA_GENERATED): $(idls)
$(ORBIT_IDL) $(idl_flags) $(top_srcdir)/calendar/idl/evolution-calendar.idl
-evolibexecdir = $(libexecdir)/evolution/$(BASE_VERSION)
-evolibexec_PROGRAMS = evolution-alarm-notify
+privlibexec_PROGRAMS = evolution-alarm-notify
noinst_LIBRARIES = libalarm.a
@@ -28,15 +27,11 @@ INCLUDES = \
-I$(top_srcdir)/libical/src/libical \
-I$(top_builddir)/libical/src/libical \
-I$(top_srcdir)/widgets \
- -I$(includedir) \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
$(EVOLUTION_CALENDAR_CFLAGS)
-gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
-
glade_DATA = \
alarm-notify.glade
@@ -63,19 +58,16 @@ evolution_alarm_notify_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(EVOLUTION_CALENDAR_LIBS)
-evolution_alarm_notify_LDFLAGS = -export-dynamic
-
-serversdir = $(libdir)/bonobo/servers
-servers_in_files = \
+server_in_files = \
GNOME_Evolution_Calendar_AlarmNotify.server.in
-servers_DATA = $(servers_in_files:.server.in=.server)
+server_DATA = $(server_in_files:.server.in=.server)
@INTLTOOL_SERVER_RULE@
EXTRA_DIST = \
- $(servers_DATA) \
- $(servers_in_files) \
+ $(server_DATA) \
+ $(server_in_files) \
$(glade_DATA)
BUILT_SOURCES = $(CORBA_GENERATED)