aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/alarm-notify/Makefile.am
diff options
context:
space:
mode:
authorLarry Ewing <lewing@ximian.com>2001-10-19 03:59:05 +0800
committerLarry Ewing <lewing@src.gnome.org>2001-10-19 03:59:05 +0800
commit2a22b3d668b277ff354d767635a7c6067360645a (patch)
tree16a70b380c47b4704ea6b20a4e9b9be2084febfc /calendar/gui/alarm-notify/Makefile.am
parentcb0ed210287eb3f4b81376a0cbe72661af0f7756 (diff)
downloadgsoc2013-evolution-2a22b3d668b277ff354d767635a7c6067360645a.tar
gsoc2013-evolution-2a22b3d668b277ff354d767635a7c6067360645a.tar.gz
gsoc2013-evolution-2a22b3d668b277ff354d767635a7c6067360645a.tar.bz2
gsoc2013-evolution-2a22b3d668b277ff354d767635a7c6067360645a.tar.lz
gsoc2013-evolution-2a22b3d668b277ff354d767635a7c6067360645a.tar.xz
gsoc2013-evolution-2a22b3d668b277ff354d767635a7c6067360645a.tar.zst
gsoc2013-evolution-2a22b3d668b277ff354d767635a7c6067360645a.zip
add html widget (url_requested_cb): add function to load images from file
2001-10-18 Larry Ewing <lewing@ximian.com> * gui/alarm-notify/alarm-notify-dialog.c: add html widget (url_requested_cb): add function to load images from file as they are requested. (write_html_heading): convert to using html. (alarm_notify_dialog): convert to use html display. (make_html_display): this is the function the custom widget in the galde file uses to create the html widget. * gui/alarm-notify/alarm-notify.glade: add placeholder for the custom html widget. * gui/alarm-notify/Makefile.am: add flags for gtkhtml and gal. svn path=/trunk/; revision=13766
Diffstat (limited to 'calendar/gui/alarm-notify/Makefile.am')
-rw-r--r--calendar/gui/alarm-notify/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/calendar/gui/alarm-notify/Makefile.am b/calendar/gui/alarm-notify/Makefile.am
index 8cf9b749fc..26965fffea 100644
--- a/calendar/gui/alarm-notify/Makefile.am
+++ b/calendar/gui/alarm-notify/Makefile.am
@@ -28,13 +28,18 @@ INCLUDES = \
-I$(top_builddir)/libical/src/libical \
-I$(top_srcdir)/widgets \
-I$(includedir) \
+ $(GAL_CFLAGS) \
$(BONOBO_VFS_GNOME_CFLAGS) \
$(BONOBO_CONF_CFLAGS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
$(EXTRA_GNOME_CFLAGS) \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\"
+iconsdir = $(datadir)/images/evolution
+
gladedir = $(datadir)/evolution/glade
glade_DATA = \
@@ -58,9 +63,12 @@ evolution_alarm_notify_LDADD = \
$(top_builddir)/calendar/cal-util/libcal-util.la \
$(top_builddir)/libical/src/libical/libical.la \
$(top_builddir)/libwombat/libwombat.la \
+ $(top_builddir)/e-util/libeutil.la \
$(BONOBO_CONF_LIBS) \
$(BONOBO_VFS_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
$(EXTRA_GNOME_LIBS) \
+ $(GAL_LIBS) \
$(INTLLIBS)
oafdir = $(datadir)/oaf