aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/alarm-notify/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2001-01-10 05:37:33 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2001-01-10 05:37:33 +0800
commit0a3ef04d1b421df60ad6876c9bae6265e9ba85da (patch)
tree89f383feb971b6191bf48bec642f5943db8ac8e0 /calendar/gui/alarm-notify/Makefile.am
parent3ad4def2b79353a0b154e58c39b026c76817397f (diff)
downloadgsoc2013-evolution-0a3ef04d1b421df60ad6876c9bae6265e9ba85da.tar
gsoc2013-evolution-0a3ef04d1b421df60ad6876c9bae6265e9ba85da.tar.gz
gsoc2013-evolution-0a3ef04d1b421df60ad6876c9bae6265e9ba85da.tar.bz2
gsoc2013-evolution-0a3ef04d1b421df60ad6876c9bae6265e9ba85da.tar.lz
gsoc2013-evolution-0a3ef04d1b421df60ad6876c9bae6265e9ba85da.tar.xz
gsoc2013-evolution-0a3ef04d1b421df60ad6876c9bae6265e9ba85da.tar.zst
gsoc2013-evolution-0a3ef04d1b421df60ad6876c9bae6265e9ba85da.zip
New interface for the alarm notification system.
2001-01-09 Federico Mena Quintero <federico@helixcode.com> * idl/evolution-calendar.idl (AlarmNotify): New interface for the alarm notification system. * gui/alarm-notify: New directory for the alarm notification daemon and its auxiliary stuff. * gui/alarm-notify/alarm.[ch]: Moved over from gui/alarm.[ch]. * gui/alarm-notify/alarm-queue.[ch]: Moved over from gui/alarm-notify.[ch]. Renamed functions from alarm_notify_*() to alarm_queue_*(). * gui/alarm-notify/alarm-notify.[ch]: Implementation of the GNOME::Evolution::Calendar::AlarmNotify interface. * gui/Makefile.am (evolution_calendar_LDADD): Removed the LINK_FLAGS variable and reordered the libraries to remove some duplicated ones. (SUBDIRS): Added the alarm-notify directory. svn path=/trunk/; revision=7338
Diffstat (limited to 'calendar/gui/alarm-notify/Makefile.am')
-rw-r--r--calendar/gui/alarm-notify/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/calendar/gui/alarm-notify/Makefile.am b/calendar/gui/alarm-notify/Makefile.am
new file mode 100644
index 0000000000..2bfdfa38df
--- /dev/null
+++ b/calendar/gui/alarm-notify/Makefile.am
@@ -0,0 +1,50 @@
+CORBA_GENERATED = \
+ evolution-calendar.h \
+ evolution-calendar-common.c \
+ evolution-calendar-skels.c \
+ evolution-calendar-stubs.c
+
+idls = $(top_srcdir)/calendar/idl/evolution-calendar.idl
+
+idl_flags = `$(GNOME_CONFIG) --cflags idl` -I $(datadir)/idl
+
+$(CORBA_GENERATED): $(idls)
+ $(ORBIT_IDL) $(idl_flags) $(top_srcdir)/calendar/idl/evolution-calendar.idl
+
+bin_PROGRAMS = evolution-alarm-notify
+
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"evolution-alarm-notify\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/calendar \
+ -I$(top_srcdir)/libical/src/libical \
+ -I$(top_builddir)/libical/src/libical \
+ -I$(top_srcdir)/widgets \
+ -I$(includedir) \
+ $(BONOBO_VFS_GNOME_CFLAGS) \
+ $(EXTRA_GNOME_CFLAGS) \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\"
+
+gladedir = $(datadir)/evolution/glade
+
+evolution_alarm_notify_SOURCES = \
+ notify-main.c
+
+evolution_alarm_notify_LDADD = \
+ $(top_builddir)/calendar/cal-client/libcal-client.la \
+ $(top_builddir)/calendar/cal-util/libcal-util.la \
+ $(top_builddir)/libical/src/libical/libical.la \
+ $(BONOBO_VFS_GNOME_LIBS) \
+ $(EXTRA_GNOME_LIBS) \
+ $(INTLLIBS)
+
+oafdir = $(datadir)/oaf
+oaf_DATA = GNOME_Evolution_Calendar_AlarmNotify.oafinfo
+
+EXTRA_DIST = \
+ $(oaf_DATA)
+
+BUILT_SOURCES = $(CORBA_GENERATED)
+CLEANFILES += $(BUILT_SOURCES)