aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorChenthill Palanisamy <pchen@src.gnome.org>2007-06-04 09:43:27 +0800
committerChenthill Palanisamy <pchen@src.gnome.org>2007-06-04 09:43:27 +0800
commitfaad8a01e1a4fc4d425ed2ff850158339fb6bd37 (patch)
treeb8be0cb43801b31d3573e5b0968d9e252dedb239 /calendar/gui/Makefile.am
parent8bebb05056fd093d0302546fc65edb130c3c136a (diff)
downloadgsoc2013-evolution-faad8a01e1a4fc4d425ed2ff850158339fb6bd37.tar
gsoc2013-evolution-faad8a01e1a4fc4d425ed2ff850158339fb6bd37.tar.gz
gsoc2013-evolution-faad8a01e1a4fc4d425ed2ff850158339fb6bd37.tar.bz2
gsoc2013-evolution-faad8a01e1a4fc4d425ed2ff850158339fb6bd37.tar.lz
gsoc2013-evolution-faad8a01e1a4fc4d425ed2ff850158339fb6bd37.tar.xz
gsoc2013-evolution-faad8a01e1a4fc4d425ed2ff850158339fb6bd37.tar.zst
gsoc2013-evolution-faad8a01e1a4fc4d425ed2ff850158339fb6bd37.zip
Added advanced search options.
svn path=/trunk/; revision=33648
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index efb573ebce..2fa778b85c 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -51,6 +51,11 @@ ecalendarincludedir = $(privincludedir)/calendar/gui
ecalendarinclude_HEADERS = \
e-cal-config.h
+search_files = tasktypes.xml memotypes.xml caltypes.xml
+
+ruledir = $(privdatadir)
+rule_DATA = $(search_files)
+
INCLUDES = \
-DG_LOG_DOMAIN=\"calendar-gui\" \
-I$(top_builddir)/shell \
@@ -60,6 +65,7 @@ INCLUDES = \
-I$(top_srcdir)/widgets \
-I$(top_srcdir)/widgets/misc \
-I$(top_srcdir)/a11y/calendar \
+ -DSEARCH_RULE_DIR=\"$(ruledir)\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
-DEVOLUTION_GALVIEWSDIR=\""$(viewsdir)"\" \
@@ -235,6 +241,7 @@ libevolution_calendar_la_LIBADD = \
$(top_builddir)/calendar/importers/libevolution-calendar-importers.la \
$(top_builddir)/widgets/e-timezone-dialog/libetimezonedialog.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/filter/libfilter.la \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/a11y/calendar/libevolution-calendar-a11y.la \
$(LIBSOUP_LIBS) \
@@ -261,7 +268,8 @@ EXTRA_DIST = \
$(glade_DATA) \
$(schema_in_files) \
$(etspec_DATA) \
- $(server_in_files)
+ $(server_in_files) \
+ $(search_files)
BUILT_SOURCES = $(IDL_GENERATED) $(server_DATA)
CLEANFILES = $(BUILT_SOURCES)