aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-06 09:58:30 +0800
committerDan Winship <danw@src.gnome.org>2003-02-06 09:58:30 +0800
commit89087493e833b711d4264de1ba924d369bd2b8ba (patch)
treee2f97f9a6de5929102a1e75f12bf09849a2b358e /calendar/gui/Makefile.am
parent0494cd37730ddca4932352cdee09d702a546ca55 (diff)
downloadgsoc2013-evolution-89087493e833b711d4264de1ba924d369bd2b8ba.tar
gsoc2013-evolution-89087493e833b711d4264de1ba924d369bd2b8ba.tar.gz
gsoc2013-evolution-89087493e833b711d4264de1ba924d369bd2b8ba.tar.bz2
gsoc2013-evolution-89087493e833b711d4264de1ba924d369bd2b8ba.tar.lz
gsoc2013-evolution-89087493e833b711d4264de1ba924d369bd2b8ba.tar.xz
gsoc2013-evolution-89087493e833b711d4264de1ba924d369bd2b8ba.tar.zst
gsoc2013-evolution-89087493e833b711d4264de1ba924d369bd2b8ba.zip
Remove cruft. Rename ICONSDIR to IMAGESDIR. (gladedir, etspecdir,
* gui/Makefile.am (INCLUDES): Remove cruft. Rename ICONSDIR to IMAGESDIR. (gladedir, etspecdir, serverdir): Remove definitions (libevolution_calendar_la_LDFLAGS): Remove -export-dynamic, add -module. * gui/calendar-config.c: #include <string.h> * gui/calendar-component.c (add_creatable_item): s/ICONSDIR/IMAGESDIR/ * gui/comp-util.c: #include <string.h> * gui/e-alarm-list.c: #include e-time-utils.h (row_deleted): Remove unused variable. (e_alarm_list_append): Likewise. * gui/e-date-time-list.c: #include e-time-utils.h, timeutil.h, calendar-config.h (row_deleted): Remove unused variable (e_date_time_list_append): Likewise. * gui/e-day-view.c (e_day_view_unrealize): Remove unused var (e_day_view_style_set): Likewise. (e_day_view_set_event_font_cb): Likewise. * gui/e-day-view-time-item.c: #include <string.h> (e_day_view_time_item_get_column_width): Remove unused variable. * gui/e-itip-control.c: #include <unistd.h> (url_requested_cb): s/ICONSDIR/IMAGESDIR/ * gui/e-week-view.c (e_week_view_unrealize): Remove unused variable (e_week_view_style_set): Likewise * gui/e-week-view-titles-item.c: #include string.h * gui/itip-bonobo-control.c: Likewise * gui/print.c: Likewise svn path=/trunk/; revision=19794
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am47
1 files changed, 20 insertions, 27 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 64095ab21f..b3f9041c9e 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -33,36 +33,31 @@ SUBDIRS = alarm-notify dialogs
component_LTLIBRARIES = libevolution-calendar.la
-INCLUDES = \
- -DG_LOG_DOMAIN=\"calendar-gui\" \
- -I$(top_builddir)/shell \
- -I$(top_srcdir)/shell \
- -I$(top_srcdir) \
- -I$(top_srcdir)/calendar \
- -I$(top_srcdir)/calendar/cal-client \
- -I$(top_builddir)/calendar/cal-client \
- -I$(top_srcdir)/libical/src/libical \
- -I$(top_builddir)/libical/src/libical \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
- -I$(top_srcdir)/widgets \
- -I$(includedir) \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(datadir)"/evolution-$(BASE_VERSION)/images\" \
- -DEVOLUTION_GALVIEWSDIR=\""$(datadir)"/evolution-$(BASE_VERSION)/views\" \
- -DEVOLUTION_UIDIR=\""$(evolutionuidir)\"" \
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"calendar-gui\" \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/calendar \
+ -I$(top_srcdir)/calendar/cal-client \
+ -I$(top_builddir)/calendar/cal-client \
+ -I$(top_srcdir)/libical/src/libical \
+ -I$(top_builddir)/libical/src/libical \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ -I$(top_srcdir)/widgets \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
+ -DEVOLUTION_GALVIEWSDIR=\""$(viewsdir)"\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
$(EVOLUTION_CALENDAR_CFLAGS)
-gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
glade_DATA = \
e-itip-control.glade \
goto-dialog.glade
-etspecdir = $(datadir)/evolution-$(BASE_VERSION)/etspec/
etspec_DATA = e-calendar-table.etspec e-meeting-time-sel.etspec
libevolution_calendar_la_SOURCES = \
@@ -177,12 +172,10 @@ libevolution_calendar_la_LIBADD = \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
$(EVOLUTION_CALENDAR_LIBS)
-libevolution_calendar_la_LDFLAGS = \
- -export-dynamic -avoid-version
+libevolution_calendar_la_LDFLAGS = -avoid-version -module
server_in_files = GNOME_Evolution_Calendar.server.in.in
-serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@