aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@ximian.com>2001-02-27 04:21:53 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2001-02-27 04:21:53 +0800
commite45e270823acb300fd0fc17e685aecb075f1a0b7 (patch)
tree13dea5d2ba6a14300e1c21800cdaa63d68527d13 /calendar/gui/Makefile.am
parenta596227e1c1b3225751a276e9efab60e9eea4110 (diff)
downloadgsoc2013-evolution-e45e270823acb300fd0fc17e685aecb075f1a0b7.tar
gsoc2013-evolution-e45e270823acb300fd0fc17e685aecb075f1a0b7.tar.gz
gsoc2013-evolution-e45e270823acb300fd0fc17e685aecb075f1a0b7.tar.bz2
gsoc2013-evolution-e45e270823acb300fd0fc17e685aecb075f1a0b7.tar.lz
gsoc2013-evolution-e45e270823acb300fd0fc17e685aecb075f1a0b7.tar.xz
gsoc2013-evolution-e45e270823acb300fd0fc17e685aecb075f1a0b7.tar.zst
gsoc2013-evolution-e45e270823acb300fd0fc17e685aecb075f1a0b7.zip
Create a little stand-alone library for the low-level alarm trigger
2001-02-26 Federico Mena Quintero <federico@ximian.com> * gui/alarm-notify/Makefile.am (libalarm_a_SOURCES): Create a little stand-alone library for the low-level alarm trigger mechanism. This is so that the GUI parts of the calendar can use it in addition to the alarm daemon. * gui/main.c: #include "alarm-notify/alarm.h". * gui/calendar-summary.c: Likewise. (alarm_fn): Do not remove the previous alarm; it is removed automatically when it is triggered. * gui/Makefile.am (evolution_calendar_SOURCES): Removed alarm.[ch] from the sources. * gui/alarm.[ch]: Removed obsolete files. svn path=/trunk/; revision=8394
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index d6b7e6edea..bf3a7f200e 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -14,7 +14,6 @@ $(IDL_GENERATED): $(IDLS)
$(srcdir)/../../composer/Evolution-Composer.idl
SUBDIRS = alarm-notify dialogs
-#SUBDIRS = dialogs
help_base = $(datadir)/gnome/help/cal
@@ -47,8 +46,6 @@ glade_DATA = \
evolution_calendar_SOURCES = \
$(IDL_GENERATED) \
- alarm.c \
- alarm.h \
calendar-config.c \
calendar-config.h \
calendar-commands.c \
@@ -114,6 +111,7 @@ evolution_calendar_SOURCES = \
widget-util.h
evolution_calendar_LDADD = \
+ alarm-notify/libalarm.a \
$(top_builddir)/shell/libeshell.a \
$(top_builddir)/calendar/cal-client/libcal-client.la \
$(top_builddir)/calendar/cal-util/libcal-util.la \