aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-11-13 02:53:08 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-11-13 02:53:08 +0800
commitddae78720c0cdc7984cc50e41a0db99368244e3d (patch)
treed078c6c4d056aa880202b460f2ef466d60d95b57 /calendar/gui/Makefile.am
parent25addba20906ecf76e9a819facb9b296069f562b (diff)
downloadgsoc2013-evolution-ddae78720c0cdc7984cc50e41a0db99368244e3d.tar
gsoc2013-evolution-ddae78720c0cdc7984cc50e41a0db99368244e3d.tar.gz
gsoc2013-evolution-ddae78720c0cdc7984cc50e41a0db99368244e3d.tar.bz2
gsoc2013-evolution-ddae78720c0cdc7984cc50e41a0db99368244e3d.tar.lz
gsoc2013-evolution-ddae78720c0cdc7984cc50e41a0db99368244e3d.tar.xz
gsoc2013-evolution-ddae78720c0cdc7984cc50e41a0db99368244e3d.tar.zst
gsoc2013-evolution-ddae78720c0cdc7984cc50e41a0db99368244e3d.zip
Clear the rdate and exrule lists from the component if we are setting a
2000-11-12 Federico Mena Quintero <federico@helixcode.com> * gui/event-editor.c (recur_to_comp_object): Clear the rdate and exrule lists from the component if we are setting a simple recurrence. (recur_to_comp_object): Set the exdate list here instead of in dialog_to_comp_object(). (preview_recur): New function to tag the recurrence preview calendar based on the information from the dialog box. (fill_exception_widgets): Fill the exception widgets here; moved over from fill_widgets(). (fill_recurrence_widgets): Call preview_recur(). Also, call fill_exception_widgets() first of all. (recurrence_type_toggled_cb): Call preview_recur(). (recur_interval_selection_done_cb): Likewise. (recur_ending_selection_done_cb): Likewise. (recurrence_exception_add_cb): Likewise. (recurrence_exception_modify_cb): Likewise. (recurrence_exception_delete_cb): Likewise. (date_changed_cb): Likewise. (recur_interval_value_changed_cb): Likewise, new function. * gui/tag-calendar.[ch]: New files with utilities for tagging calendars. mark.[ch] should go away some day. * gui/tag-calendar.c (tag_calendar): Moved over from gnome_calendar_tag_calendar(). Take in a CalClient instead of a GnomeCalendar. Added API docs. (tag_calendar_by_comp): New function to tag a calendar based on a single calendar component instead of a whole client. * gui/gnome-cal.c (initial_load): Use tag_calendar_by_client(). (obj_updated_cb): Likewise. (obj_removed_cb): Likewise. (gnome_calendar_on_date_navigator_date_range_changed): Likewise. (editor_closed_cb): Free the closure. (destroy_editor_cb): Renamed from free_uid(). Do not free the UID; just unref the event editor. Our destroy handler to it will free things properly. This will also cause the corresponding calendar client to be unrefed. (editor_closed_cb): Use a flag on the GnomeCalendar to decide whether to remove the editor from the hash table. This is sort of icky. * gui/calendar-model.c (obj_updated_cb): If the object is new, we have to use e_table_model_row_inserted(), not row_changed(). Thanks to JP Rosevear for reporting this. * gui/Makefile.am (evolution_calendar_SOURCES): Added tag-calendar.[ch] to the list of sources. svn path=/trunk/; revision=6547
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 331c0c68ee..9a4c7a300e 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -113,6 +113,8 @@ evolution_calendar_SOURCES = \
print.c \
print.h \
prop.c \
+ tag-calendar.c \
+ tag-calendar.h \
weekday-picker.c \
weekday-picker.h