aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-05-25 13:55:59 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-05-25 13:55:59 +0800
commitbb241192eb773d7f0d178306dd55f9ca8e31c1f0 (patch)
tree4201777027364eeea243b2f625bb373bca30ef6d /calendar/gui/Makefile.am
parente90eea58a2109961faa8632ac5e5783d9970366b (diff)
downloadgsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.gz
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.bz2
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.lz
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.xz
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.tar.zst
gsoc2013-evolution-bb241192eb773d7f0d178306dd55f9ca8e31c1f0.zip
Reorganized the shell to allow dynamic registration of storages and
folder types, and changed all the components to work with the new setup. svn path=/trunk/; revision=3199
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 972cb893fd..737a1df49a 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -7,6 +7,8 @@ CPPFLAGS = \
INCLUDES = \
-DG_LOG_DOMAIN=\"calendar-gui\" \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
-I$(top_srcdir) \
-I$(top_srcdir)/calendar \
-I$(top_srcdir)/libical/src/libical \
@@ -39,6 +41,10 @@ evolution_calendar_SOURCES = \
alarm.h \
calendar-commands.c \
calendar-commands.h \
+ control-factory.c \
+ control-factory.h \
+ component-factory.c \
+ component-factory.h \
e-day-view-main-item.c \
e-day-view-main-item.h \
e-day-view-time-item.c \
@@ -59,7 +65,6 @@ evolution_calendar_SOURCES = \
event-editor.h \
event-editor-utils.c \
event-editor-utils.h \
- evolution-calendar-control.c \
getdate.y \
gncal-todo.c \
gncal-todo.h \
@@ -70,6 +75,7 @@ evolution_calendar_SOURCES = \
goto.c \
layout.c \
layout.h \
+ main.c \
mark.c \
mark.h \
popup-menu.c \
@@ -78,7 +84,15 @@ evolution_calendar_SOURCES = \
print.h \
prop.c
+# FIXME We should make a libeshell library instead of this gross hack.
+SHELL_OBJS = \
+ $(top_builddir)/shell/Evolution-common.o \
+ $(top_builddir)/shell/Evolution-stubs.o \
+ $(top_builddir)/shell/Evolution-skels.o \
+ $(top_builddir)/shell/evolution-shell-component.o
+
evolution_calendar_LDADD = \
+ $(SHELL_OBJS) \
$(EXTRA_GNOME_LIBS) \
$(BONOBO_HTML_GNOME_LIBS) \
$(top_builddir)/widgets/e-text/libetext.a \
@@ -89,10 +103,10 @@ evolution_calendar_LDFLAGS = `gnome-config --libs gdk_pixbuf`
if USING_OAF
oafdir = $(datadir)/oaf
-oaf_DATA = calendar-control.oafinfo
+oaf_DATA = calendar-control.oafinfo evolution-calendar.oafinfo
else
gnorbadir = $(sysconfdir)/CORBA/servers
-gnorba_DATA = calendar-control.gnorba
+gnorba_DATA = calendar-control.gnorba evolution-calendar.gnorba
endif
EXTRA_DIST = \