aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-03-06 08:10:24 +0800
committerSeth Alves <alves@src.gnome.org>2000-03-06 08:10:24 +0800
commit34eff34dd935025d733904b03b20c764637d688a (patch)
treee9fd8dde3aac89e40d54cc030c1d0ddd823b2d52 /calendar/gui/Makefile.am
parent70108e31eafba17f63a04375d7e4c51c7d1c35eb (diff)
downloadgsoc2013-evolution-34eff34dd935025d733904b03b20c764637d688a.tar
gsoc2013-evolution-34eff34dd935025d733904b03b20c764637d688a.tar.gz
gsoc2013-evolution-34eff34dd935025d733904b03b20c764637d688a.tar.bz2
gsoc2013-evolution-34eff34dd935025d733904b03b20c764637d688a.tar.lz
gsoc2013-evolution-34eff34dd935025d733904b03b20c764637d688a.tar.xz
gsoc2013-evolution-34eff34dd935025d733904b03b20c764637d688a.tar.zst
gsoc2013-evolution-34eff34dd935025d733904b03b20c764637d688a.zip
stubs for client side access to alarm structures. this will probably
* cal-client/cal-client-alarm.c: stubs for client side access to alarm structures. this will probably change, since i don't know what i'm doing. * cal-util/alarm-enums.h: enums for alarms needed by both the client and the server * remaining source files in calendar/... have been moved to calendar/gui. * gui/alarm.c: start to decouple the view from the model in the alarm editing code svn path=/trunk/; revision=2062
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am28
1 files changed, 16 insertions, 12 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 40e1357a62..3847cb9238 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = doc idl cal-util pcs cal-client
+
idldir = $(datadir)/idl
idl_DATA = \
@@ -12,15 +12,16 @@ gnorba_DATA = \
help_base = $(datadir)/gnome/help/cal
+
+bin_PROGRAMS = gnomecal $(extra_pilot_bins)
+
if HAVE_GNOME_PILOT
extra_pilot_bins = \
calendar-conduit-control-applet \
calendar-pilot-sync
endif
-bin_PROGRAMS = gnomecal $(extra_pilot_bins)
-
-ICAL_LINK_FLAGS = ../libical/src/libical/libical.la
+ICAL_LINK_FLAGS = $(top_srcdir)/libical/src/libical/libical.la
INCLUDES = \
-I$(includedir) \
@@ -28,6 +29,7 @@ INCLUDES = \
$(GNOME_CONDUIT_INCLUDEDIR) \
$(PISOCK_INCLUDEDIR) \
-I$(top_srcdir) \
+ -I$(top_srcdir)/calendar \
-I$(top_srcdir)/libical/src/libical \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
@@ -41,10 +43,10 @@ GNOMECAL_CORBA_GENERATED = \
$(GNOMECAL_CORBA_GENERATED): GnomeCal.idl
$(ORBIT_IDL) $(idl_flags) $(srcdir)/GnomeCal.idl
-corba-cal.c \
-corba-cal.h \
-corba-cal-factory.c \
-corba-cal-factory.h: GnomeCal.h
+#corba-cal.c \
+#corba-cal.h \
+#corba-cal-factory.c \
+#corba-cal-factory.h: GnomeCal.h
gnomecal_SOURCES = \
GnomeCal-common.c \
@@ -52,7 +54,6 @@ gnomecal_SOURCES = \
GnomeCal.h \
alarm.c \
alarm.h \
- calendar-conduit.h \
eventedit.c \
eventedit.h \
corba-cal.c \
@@ -118,9 +119,10 @@ calendar_pilot_sync_SOURCES = \
LINK_FLAGS = \
$(BONOBO_VFS_GNOME_LIBS) \
$(INTLLIBS) \
- cal-util/libcalutil.la \
- ../libversit/libversit.la \
- $(ICAL_LINK_FLAGS)
+ $(top_srcdir)/calendar/cal-util/libcalutil.la \
+ $(top_srcdir)/libversit/libversit.la \
+ $(ICAL_LINK_FLAGS) \
+ $(top_srcdir)/calendar/cal-client/libcal-client.la
calendar_pilot_sync_LDADD = \
$(PISOCK_LIBDIR) $(PISOCK_LIBS) \
@@ -136,6 +138,7 @@ endif
libcalendar_conduit_la_SOURCES = \
GnomeCal-common.c \
GnomeCal-stubs.c \
+ calendar-conduit.h \
calendar-conduit.c \
calobj.c \
alarm.c \
@@ -234,3 +237,4 @@ Productivity_DATA = gncal.desktop
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(help_base)/C
$(mkinstalldirs) $(Conduitsdir)
+