aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-04-09 04:21:31 +0800
committerSeth Alves <alves@src.gnome.org>2000-04-09 04:21:31 +0800
commit181e276c46263a695457f4c250c917560d6e1596 (patch)
tree723f398a2812c049fe0ce078b8e9b7efad4113de /calendar/gui/Makefile.am
parent4c1b64ea55dc20faa79c79f85fb53d04d956315b (diff)
downloadgsoc2013-evolution-181e276c46263a695457f4c250c917560d6e1596.tar
gsoc2013-evolution-181e276c46263a695457f4c250c917560d6e1596.tar.gz
gsoc2013-evolution-181e276c46263a695457f4c250c917560d6e1596.tar.bz2
gsoc2013-evolution-181e276c46263a695457f4c250c917560d6e1596.tar.lz
gsoc2013-evolution-181e276c46263a695457f4c250c917560d6e1596.tar.xz
gsoc2013-evolution-181e276c46263a695457f4c250c917560d6e1596.tar.zst
gsoc2013-evolution-181e276c46263a695457f4c250c917560d6e1596.zip
new function: friendly wrapper for cal_client_create_calendar
* gui/gnome-cal.c (gnome_calendar_create): new function: friendly wrapper for cal_client_create_calendar * gui/calendar-commands.c (new_calendar): call gnome_calendar_create if no filename is provided * gui/prop.c (properties): calendar is a frame * gui/calendar-commands.c (calendar_control_activate): sort out the menus a bit, more of them show up now. * gui/Makefile.am: don't build library or test, just the bonobo control * gui/gncal-todo.c (simple_todo_editor): calendar is a frame instead of a window, now. * gui/gnome-cal.c (gnome_calendar_new): same * gui/goto.c (goto_dialog): same svn path=/trunk/; revision=2339
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am22
1 files changed, 4 insertions, 18 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 6f35ed7ed2..15f1492739 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -28,9 +28,8 @@ LINK_FLAGS = \
$(top_builddir)/libical/src/libical/libical.la \
$(top_builddir)/calendar/cal-client/libcal-client.la
-noinst_LIBRARIES = libcalendarwidget.a
-
-libcalendarwidget_a_SOURCES = \
+bin_PROGRAMS = evolution-calendar
+evolution_calendar_SOURCES = \
alarm.c \
alarm.h \
e-day-view-main-item.c \
@@ -76,25 +75,12 @@ libcalendarwidget_a_SOURCES = \
year-view.c \
year-view.h \
calendar-commands.c \
- calendar-commands.h
-
-
-bin_PROGRAMS = evolution-calendar
-noinst_PROGRAMS = test-calendar-widget
-test_calendar_widget_SOURCES = main.c
-test_calendar_widget_INCLUDES = \
- $(INCLUDES) \
- -DG_LOG_DOMAIN=\"test-calendar-widget\"
-test_calendar_widget_LDADD = \
- libcalendarwidget.a \
- $(LINK_FLAGS)
-
-evolution_calendar_SOURCES = evolution-calendar-control.c
+ calendar-commands.h \
+ evolution-calendar-control.c
evolution_calendar_LDADD = \
$(EXTRA_GNOME_LIBS) \
$(BONOBO_HTML_GNOME_LIBS) \
- $(top_builddir)/calendar/gui/libcalendarwidget.a \
$(top_builddir)/widgets/e-minicard/libeminicard.a \
$(top_builddir)/widgets/e-table/libetable.a \
$(top_builddir)/widgets/e-text/libetext.a \