aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-05-26 22:22:52 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-05-26 22:22:52 +0800
commit144db69758bcf971327694704421f5b5a5e3a0e8 (patch)
treeda649fd81cd8eca6f1696017cc4449611e17f7cc /calendar/gui/Makefile.am
parentaf35801677cee7603f32272c161400b7ec0e5721 (diff)
downloadgsoc2013-evolution-144db69758bcf971327694704421f5b5a5e3a0e8.tar
gsoc2013-evolution-144db69758bcf971327694704421f5b5a5e3a0e8.tar.gz
gsoc2013-evolution-144db69758bcf971327694704421f5b5a5e3a0e8.tar.bz2
gsoc2013-evolution-144db69758bcf971327694704421f5b5a5e3a0e8.tar.lz
gsoc2013-evolution-144db69758bcf971327694704421f5b5a5e3a0e8.tar.xz
gsoc2013-evolution-144db69758bcf971327694704421f5b5a5e3a0e8.tar.zst
gsoc2013-evolution-144db69758bcf971327694704421f5b5a5e3a0e8.zip
Put the main notebook directly under a simple GtkWindow. We are going to
2000-05-25 Federico Mena Quintero <federico@helixcode.com> * gui/event-editor-dialog.glade: Put the main notebook directly under a simple GtkWindow. We are going to pull out the notebook and slap it into our custom-built GnomeApp, anwyays. * gui/event-editor.c: Made the EventEditor derive from GnomeApp. Added a BonoboUIHandler for its menu and toolbar. (make_title_from_ico): Create a nice title for the window. (get_widgets): Fetch the Glade widgets here instead of all over the place. (event_editor_new): Temporary hack to show the dialog here, just so that I can test it. * gui/Makefile.am (EXTRA_DIST): Added the Glade messages file. svn path=/trunk/; revision=3214
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 7b4968a9c5..d1d65a344f 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -34,6 +34,8 @@ LINK_FLAGS = \
gladedir = $(datadir)/evolution/glade
glade_DATA = event-editor-dialog.glade
+glade_messages = event-editor-dialog.glade.h
+
bin_PROGRAMS = evolution-calendar
evolution_calendar_SOURCES = \
@@ -110,15 +112,16 @@ gnorbadir = $(sysconfdir)/CORBA/servers
gnorba_DATA = calendar-control.gnorba evolution-calendar.gnorba
endif
-EXTRA_DIST = \
- bell.xpm \
- recur.xpm \
- dayview.xpm \
- workweekview.xpm \
- weekview.xpm \
- monthview.xpm \
- yearview.xpm \
- calendar-control.gnorba \
+EXTRA_DIST = \
+ $(glade_messages) \
+ bell.xpm \
+ recur.xpm \
+ dayview.xpm \
+ workweekview.xpm \
+ weekview.xpm \
+ monthview.xpm \
+ yearview.xpm \
+ calendar-control.gnorba \
calendar-control.oafinfo
install-data-local: