aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorDamon Chaplin <damon@helixcode.com>2000-04-24 22:01:46 +0800
committerDamon Chaplin <damon@src.gnome.org>2000-04-24 22:01:46 +0800
commit94a486a7b4207e617da30b172aa9873e0fbb0215 (patch)
tree032fd6642291a41b61a17692bf5a69e3dd41d316 /calendar/gui/Makefile.am
parent0c3a86937674a6214f68746ee5a273e195228fde (diff)
downloadgsoc2013-evolution-94a486a7b4207e617da30b172aa9873e0fbb0215.tar
gsoc2013-evolution-94a486a7b4207e617da30b172aa9873e0fbb0215.tar.gz
gsoc2013-evolution-94a486a7b4207e617da30b172aa9873e0fbb0215.tar.bz2
gsoc2013-evolution-94a486a7b4207e617da30b172aa9873e0fbb0215.tar.lz
gsoc2013-evolution-94a486a7b4207e617da30b172aa9873e0fbb0215.tar.xz
gsoc2013-evolution-94a486a7b4207e617da30b172aa9873e0fbb0215.tar.zst
gsoc2013-evolution-94a486a7b4207e617da30b172aa9873e0fbb0215.zip
added new source files and pixmaps, and removed old source files, which
2000-04-24 Damon Chaplin <damon@helixcode.com> * gui/Makefile.am: added new source files and pixmaps, and removed old source files, which can be deleted. * gui/e-week-view-titles-item.[hc]: * gui/e-week-view-main-item.[hc]: * gui/e-week-view-event-item.[hc]: * gui/e-week-view.[hc]: new files implementing the week/month views. * gui/yearview.xpm: * gui/monthview.xpm: * gui/weekview.xpm: * gui/workweekview.xpm: * gui/dayview.xpm: new pixmaps for the toolbar buttons. These aren't intended to be the final pixmaps. * gui/calendar-commands.c: added radio buttons to the toolbar to switch between the calendar views, and moved the am_pm_flag here so we can get rid of view-utils.c. * gui/gnome-cal.[hc]: made it a subclass of GtkVBox, rearranged the widgets into 2 notebooks, and added the selection_start_time and selection_end_time fields. * gui/goto.c: updated to use new selection time range. * gui/quick-view.c: added '#include <gtk/gtkwindow.h>' so it compiles. * gui/e-day-view.[hc]: changed the interface to support the new selection time range, got rid of a few debugging messages and changed a few bits. svn path=/trunk/; revision=2583
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am33
1 files changed, 16 insertions, 17 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 2f0dab260a..07e8ca1531 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -40,17 +40,17 @@ evolution_calendar_SOURCES = \
e-day-view-top-item.h \
e-day-view.c \
e-day-view.h \
+ e-week-view-event-item.c \
+ e-week-view-event-item.h \
+ e-week-view-main-item.c \
+ e-week-view-main-item.h \
+ e-week-view-titles-item.c \
+ e-week-view-titles-item.h \
+ e-week-view.c \
+ e-week-view.h \
eventedit.c \
eventedit.h \
getdate.y \
- gncal-day-panel.c \
- gncal-day-panel.h \
- gncal-day-view.c \
- gncal-day-view.h \
- gncal-full-day.c \
- gncal-full-day.h \
- gncal-week-view.c \
- gncal-week-view.h \
gncal-todo.c \
gncal-todo.h \
gnome-month-item.c \
@@ -58,20 +58,14 @@ evolution_calendar_SOURCES = \
gnome-cal.c \
gnome-cal.h \
goto.c \
- layout.c \
- layout.h \
mark.c \
mark.h \
- month-view.c \
- month-view.h \
popup-menu.c \
popup-menu.h \
prop.c \
quick-view.c \
quick-view.h \
todo-conduit.h \
- view-utils.h \
- view-utils.c \
year-view.c \
year-view.h \
calendar-commands.c \
@@ -182,9 +176,14 @@ gnorba_DATA = calendar-control.gnorba
#Conduits_second_DATA = $(Conduits_DATA)
#endif
-EXTRA_DIST = \
- bell.xpm \
- recur.xpm
+EXTRA_DIST = \
+ bell.xpm \
+ recur.xpm \
+ dayview.xpm \
+ workweekview.xpm \
+ weekview.xpm \
+ monthview.xpm \
+ yearview.xpm
# gnome-calendar-conduit.png
# todo-conduit-control-applet.desktop