aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-10-05 09:32:41 +0800
committerMatthew Barnes <mbarnes@redhat.com>2011-10-05 10:27:14 +0800
commit1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba (patch)
tree8b3d99bcac99c3a3edbb2939ea0226c187a39eb4 /calendar/gui/Makefile.am
parent273b10a5baebd97bea4aeb1dae158f93ce93eb72 (diff)
downloadgsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.gz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.bz2
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.lz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.xz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.zst
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.zip
Simplify library dependency flags.
We have a confusing array of nearly-identical CFLAGS/LIBS definitions in configure.ac. Time to simplify. Instead let's just have one definition that includes all the libraries provided by Evolution-Data-Server (incl. Camel). That, in combination with GNOME_PLATFORM, gives us most of what we need for compliation and linking, and we can sprinkle definitions for additional library dependencies in Makefile.am's as needed.
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 1531bb8d60..ce1f832ba3 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -67,10 +67,10 @@ libevolution_calendar_la_CPPFLAGS = \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DEVOLUTION_UIDIR=\""$(uidir)"\" \
-DPREFIX=\""$(prefix)"\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
$(GNOME_PLATFORM_CFLAGS) \
- $(LIBSOUP_CFLAGS) \
- $(EVOLUTION_CALENDAR_CFLAGS) \
- $(CAMEL_CFLAGS)
+ $(GTKHTML_CFLAGS) \
+ $(LIBSOUP_CFLAGS)
etspec_DATA = \
e-calendar-table.etspec \
@@ -213,10 +213,10 @@ libevolution_calendar_la_LIBADD = \
$(top_builddir)/widgets/table/libetable.la \
$(top_builddir)/filter/libfilter.la \
$(top_builddir)/e-util/libeutil.la \
- $(CAMEL_LIBS) \
- $(LIBSOUP_LIBS) \
- $(EVOLUTION_CALENDAR_LIBS) \
- $(GNOME_PLATFORM_LIBS)
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(LIBSOUP_LIBS)
libevolution_calendar_la_LDFLAGS = $(NO_UNDEFINED)