aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-14 05:15:25 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-14 05:15:25 +0800
commit3c89e1aa0252c6f558cf1573b39ab3a366cd4516 (patch)
treed6a3fa36c60ef5beef62f75e10f0021a20677fb5 /calendar/gui/Makefile.am
parent8b75a400feebc8b524424d4d5e4ce9001d44003a (diff)
downloadgsoc2013-evolution-3c89e1aa0252c6f558cf1573b39ab3a366cd4516.tar
gsoc2013-evolution-3c89e1aa0252c6f558cf1573b39ab3a366cd4516.tar.gz
gsoc2013-evolution-3c89e1aa0252c6f558cf1573b39ab3a366cd4516.tar.bz2
gsoc2013-evolution-3c89e1aa0252c6f558cf1573b39ab3a366cd4516.tar.lz
gsoc2013-evolution-3c89e1aa0252c6f558cf1573b39ab3a366cd4516.tar.xz
gsoc2013-evolution-3c89e1aa0252c6f558cf1573b39ab3a366cd4516.tar.zst
gsoc2013-evolution-3c89e1aa0252c6f558cf1573b39ab3a366cd4516.zip
Removed. Removed.
* gui/config-control-factory.h: Removed. * gui/config-control-factory.c: Removed. * gui/itip-bonobo-control.c: Renamed from itip-control-factory.c. (itip_bonobo_control_new): New. (itip_control_factory_init): Removed. * gui/itip-bonobo-control.h: Renamed from itip-control-factory.h. * gui/tasks-control-factory.c: Removed. * gui/tasks-control-factory.h: Removed. * gui/control-factory.c (control_factory_init): Removed. * gui/Makefile.am: Updated to build everything as libevolution-calendar.so and install in the COMPONENTDIR. * gui/GNOME_Evolution_Calendar.server.in.in: Updated to build the component as a shared library. * gui/main.c (main): Removed. * gui/calendar-component.c (calendar_component_get_object): New. (owner_set_cb): Do not store the shell pointer in shells. (owner_unset_cb): Do not remove the shell pointer from shells; instead, just set global_shell_client to NULL. * gui/calendar-component.h: Renamed from component-factory.h. * gui/calendar-component.c: Renamed from component-factory.c. svn path=/trunk/; revision=19430
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am38
1 files changed, 11 insertions, 27 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 391206c975..cf5838b5bc 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -33,7 +33,8 @@ SUBDIRS = alarm-notify dialogs
help_base = $(datadir)/gnome/help/cal
-libexec_PROGRAMS = evolution-calendar
+componentdir = $(COMPONENT_DIR)
+component_LTLIBRARIES = libevolution-calendar.la
INCLUDES = \
-DG_LOG_DOMAIN=\"calendar-gui\" \
@@ -67,7 +68,7 @@ glade_DATA = \
etspecdir = $(datadir)/evolution/etspec/
etspec_DATA = e-calendar-table.etspec e-meeting-time-sel.etspec
-evolution_calendar_SOURCES = \
+libevolution_calendar_la_SOURCES = \
$(IDL_GENERATED) \
cal-search-bar.c \
cal-search-bar.h \
@@ -75,6 +76,8 @@ evolution_calendar_SOURCES = \
calendar-config.h \
calendar-commands.c \
calendar-commands.h \
+ calendar-component.c \
+ calendar-component.h \
calendar-model.c \
calendar-model.h \
calendar-offline-handler.c \
@@ -87,12 +90,8 @@ evolution_calendar_SOURCES = \
comp-editor-factory.h \
comp-util.c \
comp-util.h \
- config-control-factory.c \
- config-control-factory.h \
control-factory.c \
control-factory.h \
- component-factory.c \
- component-factory.h \
e-calendar-table.h \
e-calendar-table.c \
e-cell-date-edit-text.h \
@@ -140,8 +139,8 @@ evolution_calendar_SOURCES = \
gnome-cal.h \
goto.c \
goto.h \
- itip-control-factory.c \
- itip-control-factory.h \
+ itip-bonobo-control.c \
+ itip-bonobo-control.h \
itip-utils.c \
itip-utils.h \
main.c \
@@ -151,8 +150,6 @@ evolution_calendar_SOURCES = \
print.h \
tag-calendar.c \
tag-calendar.h \
- tasks-control-factory.c \
- tasks-control-factory.h \
tasks-control.c \
tasks-control.h \
tasks-migrate.c \
@@ -160,7 +157,7 @@ evolution_calendar_SOURCES = \
weekday-picker.c \
weekday-picker.h
-evolution_calendar_LDADD = \
+libevolution_calendar_la_LIBADD = \
alarm-notify/libalarm.a \
$(DB3_LDADD) \
$(top_builddir)/widgets/menus/libmenus.la \
@@ -179,14 +176,12 @@ evolution_calendar_LDADD = \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
$(EVOLUTION_CALENDAR_LIBS)
-evolution_calendar_LDFLAGS = -export-dynamic
-
server_in_files = GNOME_Evolution_Calendar.server.in.in
serverdir = $(libdir)/bonobo/servers
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
- sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
+ sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
@INTLTOOL_SERVER_RULE@
@@ -195,22 +190,11 @@ EXTRA_DIST = \
$(etspec_DATA) \
$(server_in_files)
+CLEANFILES = $(BUILT_SOURCES)
+
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(help_base)/C
$(mkinstalldirs) $(Conduitsdir)
-if ENABLE_PURIFY
-PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
-
-all-local: evolution-calendar.pure
-
-evolution-calendar.pure: evolution-calendar
- @rm -f evolution-calendar.pure
- $(PLINK) $(evolution_calendar_LDFLAGS) $(evolution_calendar_OBJECTS) $(evolution_calendar_LDADD) $(LIBS)
-
-endif
-
-CLEANFILES = $(BUILT_SOURCES)
-
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)