aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2002-03-13 12:55:04 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2002-03-13 12:55:04 +0800
commitd5ba94f758a5206dc7cd5b0cd222bb2c3d348ebe (patch)
treef0ed1da36d11d0d6a12183a9f8f13bb3434e94d0 /calendar/gui/Makefile.am
parent9a3b0141daad42713cdeae13ffb0d2e8af786540 (diff)
downloadgsoc2013-evolution-d5ba94f758a5206dc7cd5b0cd222bb2c3d348ebe.tar
gsoc2013-evolution-d5ba94f758a5206dc7cd5b0cd222bb2c3d348ebe.tar.gz
gsoc2013-evolution-d5ba94f758a5206dc7cd5b0cd222bb2c3d348ebe.tar.bz2
gsoc2013-evolution-d5ba94f758a5206dc7cd5b0cd222bb2c3d348ebe.tar.lz
gsoc2013-evolution-d5ba94f758a5206dc7cd5b0cd222bb2c3d348ebe.tar.xz
gsoc2013-evolution-d5ba94f758a5206dc7cd5b0cd222bb2c3d348ebe.tar.zst
gsoc2013-evolution-d5ba94f758a5206dc7cd5b0cd222bb2c3d348ebe.zip
Add <visible>False</visible> to cal-prefs-dialog so it doesn't get shown
* gui/dialogs/cal-prefs-dialog.glade: Add <visible>False</visible> to cal-prefs-dialog so it doesn't get shown when we load the Glade file with libglade. * gui/component-factory.c (owner_set_cb): Register the ConfigControl factory. * gui/tasks-control.c: Removed verb "TaskSettings". (tasks_control_settings_cmd): Removed. * gui/calendar-commands.c: Removed verb "CalendarSettings". (settings_cmd): Removed. * gui/dialogs/cal-prefs-dialog.c: Renamed `CalPrefsDialogPrivate' to `DialogData'. Replace `dialog' member with a `page' member. Remove `toplevel_notebook' member. (init_widgets): Renamed from `cal_prefs_dialog_init_widgets'. Just get a DialogData. (get_widgets): Get a DialogData pointer. (cal_prefs_dialog_destroy): Removed. (config_control_destroy_callback): New, signal handler for ::destroy for ConfigControl. (cal_prefs_dialog_new): Create a new DialogData, connect all the signal handlers. (create_time_edit): Renamed from `cal_prefs_dialog_create_time_edit'. (cal_prefs_dialog_show): Removed. (cal_prefs_dialog_button_clicked): Removed. (show_task_list_config): Get a DialogData. (show_config): Renamed from `cal_prefs_dialog_show_config'. Likewise. (update_task_list_config): Likewise. (update_config): Renamed from `cal_prefs_dialog_update_config'. Likewise. (color_set_callback): New callback, makes the dialog report changes when the setting in any of the color widgets is changed. (widget_changed_callback): New callback, makes the dialog report changes when any of the widgets changes status. (connect_changed): New utility function to connect this callback to all the widgets. (setup_widgets): Connect all the widgets. (cal_prefs_dialog_new): Call `setup_widgets'. * gui/config-control-factory.c: New. * gui/config-control-factory.h: New. * gui/GNOME_Evolution_Calendar.oaf.in: Add OAFIID:GNOME_Evolution_Calendar_ConfigControl and OAFIID:GNOME_Evolution_Calendar_ConfigControlFactory. svn path=/trunk/; revision=16135
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 39c582c8bd..fdef37a9f7 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -87,6 +87,8 @@ evolution_calendar_SOURCES = \
comp-editor-factory.h \
comp-util.c \
comp-util.h \
+ config-control-factory.c \
+ config-control-factory.h \
control-factory.c \
control-factory.h \
component-factory.c \