aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2002-01-25 07:16:18 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2002-01-25 07:16:18 +0800
commit4ba09274d6d393568a06c483bf4934ea4707a604 (patch)
tree8bb9f22fe18024c733e233f963c621c39ed460f4 /calendar/gui/Makefile.am
parentd656b69c9bd1de52d6991e1694fd4dcf9856951c (diff)
downloadgsoc2013-evolution-4ba09274d6d393568a06c483bf4934ea4707a604.tar
gsoc2013-evolution-4ba09274d6d393568a06c483bf4934ea4707a604.tar.gz
gsoc2013-evolution-4ba09274d6d393568a06c483bf4934ea4707a604.tar.bz2
gsoc2013-evolution-4ba09274d6d393568a06c483bf4934ea4707a604.tar.lz
gsoc2013-evolution-4ba09274d6d393568a06c483bf4934ea4707a604.tar.xz
gsoc2013-evolution-4ba09274d6d393568a06c483bf4934ea4707a604.tar.zst
gsoc2013-evolution-4ba09274d6d393568a06c483bf4934ea4707a604.zip
Clean up some of the Makefiles so we dont' link every library multiple
times, causing big libtool 1.4 pain. svn path=/trunk/; revision=15461
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 20567ced8a..56fab01684 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -49,16 +49,13 @@ INCLUDES = \
-I$(top_builddir)/addressbook/backend/ebook \
-I$(top_srcdir)/widgets \
-I$(includedir) \
- $(BONOBO_HTML_GNOME_CFLAGS) \
- $(GNOME_VFS_CFLAGS) \
- $(GAL_CFLAGS) \
- $(BONOBO_CONF_CFLAGS) \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
-DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(datadir)"/images/evolution\"
+ -DEVOLUTION_IMAGESDIR=\""$(datadir)"/images/evolution\" \
+ $(EVOLUTION_CALENDAR_CFLAGS)
iconsdir = $(datadir)/images/evolution
@@ -176,12 +173,7 @@ evolution_calendar_LDADD = \
dialogs/libcal-dialogs.a \
$(top_builddir)/widgets/e-timezone-dialog/libetimezonedialog.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
- $(EXTRA_GNOME_LIBS) \
- $(BONOBO_HTML_GNOME_LIBS) \
- $(GNOME_VFS_LIBS) \
- $(BONOBO_CONF_LIBS) \
- $(GAL_LIBS) \
- $(INTLLIBS)
+ $(EVOLUTION_CALENDAR_LIBS)
evolution_calendar_LDFLAGS = -export-dynamic