aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:07:51 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:07:51 +0800
commitbc61f8e11ccdb24c8a5ad4efafb31cfb097733fe (patch)
tree21301790bbead821c66310484253c57636936c1e /calendar/gui/Makefile.am
parent274026702024e9ff9ab593e263b662d37ab4316e (diff)
downloadgsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.gz
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.bz2
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.lz
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.xz
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.zst
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.zip
Use EVOLUTION_GALVIEWSDIR.
* gui/gnome-cal.c (gnome_calendar_setup_view_menus): Use EVOLUTION_GALVIEWSDIR. * gui/e-tasks.c (e_tasks_setup_view_menus): Use EVOLUTION_GALVIEWSDIR. * cal-util/Makefile.am: Install libcal-util.la in $(privlibdir) instead of $(libdir). * gui/dialogs/comp-editor.c (setup_widgets): Get evolution-comp-editor.xml from EVOLUTION_UIDIR. (comp_editor_merge_ui): Get the file in EVOLUTION_UIDIR. * gui/tasks-control.c (tasks_control_activate): Get evolution-tasks.xml from EVOLUTION_UI_DIRECTORY. * gui/calendar-commands.c (calendar_control_activate): Get evolution-calendar.xml from EVOLUTION_UI_DIRECTORY. * pcs/Makefile.am (pcsincludedir): Version using $(BASE_VERSION). * importers/Makefile.am: Install evolution-calendar-importer in $(libexecdir)/evolution/$(BASE_VERSION). (sounddir): Remove. * gui/dialogs/Makefile.am (iconsdir): Version using $(BASE_VERSION). (gladedir): Likewise. (etspecdir): Likewise. * gui/Makefile.am (help_base): Remove. (install-data-local): Do not make the $(help_base)/C directory. (etspecdir): Version using $(BASE_VERSION). (gladedir): Likewise. (iconsdir): Likewise. (INCLUDES): Update the EVOLUTION_IMAGESDIR define to be versioned, and add a -DEVOLUTION_GALVIEWSDIR. * cal-util/Makefile.am: Install evolution-alarm-notify in $(libexecdir)/evolution/$(BASE_VERSION). * cal-util/Makefile.am (libcal_utilincludedir): Version using $(BASE_VERSION). * gui/alarm-notify/Makefile.am (iconsdir): Likewise. (gladedir): Likewise. * cal-client/Makefile.am: Install libcal-client.la in privlibdir instead of libdir. (libcal_clientincludedir): Version using $(BASE_VERSION). svn path=/trunk/; revision=19553
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am51
1 files changed, 25 insertions, 26 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 5ccdb1fec1..066e47f91e 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -31,41 +31,41 @@ BUILT_SOURCES = $(IDL_GENERATED)
SUBDIRS = alarm-notify dialogs
-help_base = $(datadir)/gnome/help/cal
-
componentdir = $(COMPONENT_DIR)
component_LTLIBRARIES = libevolution-calendar.la
-INCLUDES = \
- -DG_LOG_DOMAIN=\"calendar-gui\" \
- -I$(top_builddir)/shell \
- -I$(top_srcdir)/shell \
- -I$(top_srcdir) \
- -I$(top_srcdir)/calendar \
- -I$(top_srcdir)/calendar/cal-client \
- -I$(top_builddir)/calendar/cal-client \
- -I$(top_srcdir)/libical/src/libical \
- -I$(top_builddir)/libical/src/libical \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
- -I$(top_srcdir)/widgets \
- -I$(includedir) \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(datadir)"/evolution/images\" \
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"calendar-gui\" \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/calendar \
+ -I$(top_srcdir)/calendar/cal-client \
+ -I$(top_builddir)/calendar/cal-client \
+ -I$(top_srcdir)/libical/src/libical \
+ -I$(top_builddir)/libical/src/libical \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ -I$(top_srcdir)/widgets \
+ -I$(includedir) \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(datadir)"/evolution-$(BASE_VERSION)/images\" \
+ -DEVOLUTION_GALVIEWSDIR=\""$(datadir)"/evolution-$(BASE_VERSION)/views\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)\"" \
$(EVOLUTION_CALENDAR_CFLAGS)
-iconsdir = $(datadir)/evolution/images
+iconsdir = $(datadir)/evolution-$(BASE_VERSION)/images
-gladedir = $(datadir)/evolution/glade
+gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
glade_DATA = \
e-itip-control.glade \
goto-dialog.glade
-etspecdir = $(datadir)/evolution/etspec/
+etspecdir = $(datadir)/evolution-$(BASE_VERSION)/etspec/
etspec_DATA = e-calendar-table.etspec e-meeting-time-sel.etspec
libevolution_calendar_la_SOURCES = \
@@ -200,7 +200,6 @@ EXTRA_DIST = \
CLEANFILES = $(BUILT_SOURCES)
install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(help_base)/C
$(mkinstalldirs) $(Conduitsdir)
dist-hook: