aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2002-11-20 06:07:59 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2002-11-20 06:07:59 +0800
commit9582ff59388f35e424771b27e318410cfb81c4e0 (patch)
treec206d31248ca26e3c51793c86b2cfa877ad14f2e /calendar/gui/Makefile.am
parent9f5ba47f8481f3052cc684fcb8be8c8827debb5b (diff)
downloadgsoc2013-evolution-9582ff59388f35e424771b27e318410cfb81c4e0.tar
gsoc2013-evolution-9582ff59388f35e424771b27e318410cfb81c4e0.tar.gz
gsoc2013-evolution-9582ff59388f35e424771b27e318410cfb81c4e0.tar.bz2
gsoc2013-evolution-9582ff59388f35e424771b27e318410cfb81c4e0.tar.lz
gsoc2013-evolution-9582ff59388f35e424771b27e318410cfb81c4e0.tar.xz
gsoc2013-evolution-9582ff59388f35e424771b27e318410cfb81c4e0.tar.zst
gsoc2013-evolution-9582ff59388f35e424771b27e318410cfb81c4e0.zip
Added rule to generate GNOME_Evolution_Calendar.server.in from
* Makefile.am: Added rule to generate GNOME_Evolution_Calendar.server.in from GNOME_Evolution_Calendar.server.in.in, substituting @LIBEXECDIR@. Also, install evolution-calendar in $libexecdir instead of $bindir. * gui/GNOME_Evolution_Calendar.server.in.in: Renamed from GNOME_Evolution_Calendar.server.in. Prepended the executable name with @LIBEXECDIR@. svn path=/trunk/; revision=18847
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 37fd67eb18..b3ba603747 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -33,7 +33,7 @@ SUBDIRS = alarm-notify dialogs
help_base = $(datadir)/gnome/help/cal
-bin_PROGRAMS = evolution-calendar
+libexec_PROGRAMS = evolution-calendar
INCLUDES = \
-DG_LOG_DOMAIN=\"calendar-gui\" \
@@ -181,11 +181,12 @@ evolution_calendar_LDADD = \
evolution_calendar_LDFLAGS = -export-dynamic
-serversdir = $(libdir)/bonobo/servers
-servers_in_files = \
- GNOME_Evolution_Calendar.server.in
+server_in_files = GNOME_Evolution_Calendar.server.in.in
-servers_DATA = $(servers_in_files:.server.in=.server)
+serverdir = $(libdir)/bonobo/servers
+server_DATA = $(server_in_files:.server.in.in=.server)
+$(server_in_files:.server.in.in=.server.in): $(server_in_files)
+ sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" $< > $@
@INTLTOOL_SERVER_RULE@