aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/conduits/memo/Makefile.am
diff options
context:
space:
mode:
authorSrinivasa Ragavan <sragavan@src.gnome.org>2007-06-03 22:50:35 +0800
committerSrinivasa Ragavan <sragavan@src.gnome.org>2007-06-03 22:50:35 +0800
commit54a9260f696f5c7462f40af8f838d723ba3abeb5 (patch)
treeab87ece78582288b7dabf6635fe3f393fd042c4d /calendar/conduits/memo/Makefile.am
parentb484ae1c53ce5e8075eefe907cffbcb936106397 (diff)
downloadgsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.gz
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.bz2
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.lz
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.xz
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.zst
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.zip
Fix for version removal from installed files.
svn path=/trunk/; revision=33646
Diffstat (limited to 'calendar/conduits/memo/Makefile.am')
-rw-r--r--calendar/conduits/memo/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/calendar/conduits/memo/Makefile.am b/calendar/conduits/memo/Makefile.am
index 70494168ca..afbee4e56c 100644
--- a/calendar/conduits/memo/Makefile.am
+++ b/calendar/conduits/memo/Makefile.am
@@ -8,24 +8,25 @@ INCLUDES = \
# Memo Conduit
privconduit_LTLIBRARIES = libememo_conduit.la
-libememo_conduit_la_SOURCES = \
+libememo_conduit_la_SOURCES = \
memo-conduit.c
-libememo_conduit_la_LDFLAGS = -module -avoid-version
+libememo_conduit_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+
libememo_conduit_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/e-util/libeconduit.la \
- $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/e-util/libeconduit.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
$(EVOLUTION_CALENDAR_CONDUIT_LIBS)
-e-memo-$(BASE_VERSION).conduit: e-memo.conduit.in
- sed -e 's^\@privconduitdir\@^$(privconduitdir)^g' \
+e-memo.conduit: e-memo.conduit.in
+ sed -e 's^\@privconduitdir\@^$(privconduitdir)^g' \
-e 's^\@datadir\@^$(datadir)^g' \
-e 's^\@BASE_VERSION\@^$(BASE_VERSION)^g' \
$< > $@
conduitdir = $(datadir)/gnome-pilot/conduits/
-conduit_DATA = e-memo-$(BASE_VERSION).conduit
+conduit_DATA = e-memo.conduit
BUILT_SOURCES = $(conduit_DATA)
CLEANFILES = $(BUILT_SOURCES)