aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/cal-util/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-04-17 03:25:56 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-04-17 03:25:56 +0800
commit75f8b00ea05e5485530fb4a74af7e9afdf5345ae (patch)
treeb74f223155112d6ae34b554183a500a6e801b7f2 /calendar/cal-util/Makefile.am
parent98a15f353372d37e48f5c925c91aa2f40cbb942a (diff)
downloadgsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.gz
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.bz2
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.lz
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.xz
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.tar.zst
gsoc2013-evolution-75f8b00ea05e5485530fb4a74af7e9afdf5345ae.zip
Renamed library from libcalutil to libcal-util, to be consistent with
2000-04-16 Federico Mena Quintero <federico@helixcode.com> * cal-util/Makefile.am: Renamed library from libcalutil to libcal-util, to be consistent with libcal-client. Install header files in $(includedir)/evolution/cal-util. (INCLUDES): Add "cal-util" log domain for glib. (libcal_clientincludedir): The header files are now installed in $(includedir)/evolution/cal-client. * cal-util/cal-util.h: Fix includes. * cal-client/client-test.c: Fix includes. * pcs/Makefile.am: Create libpcs.a, not a shared library, because it is for internal use by Wombat only. The header files should not be installed, either. Removed all the old Tlacuache stuff. * gui/Makefile.am (EXTRA_DIST): We no longer distribute gncal.desktop. (evolution_calendar_INCLUDES): Add "calendar-gui" for the glib log domain. * gui/*.[ch]: Fix cal-util and cal-client includes. * pcs/Makefile.am (INCLUDES): Added "pcs" log domain for glib. * pcs/*.[ch]: Fix cal-util includes. svn path=/trunk/; revision=2461
Diffstat (limited to 'calendar/cal-util/Makefile.am')
-rw-r--r--calendar/cal-util/Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/calendar/cal-util/Makefile.am b/calendar/cal-util/Makefile.am
index 8a866efd49..248e5373e5 100644
--- a/calendar/cal-util/Makefile.am
+++ b/calendar/cal-util/Makefile.am
@@ -1,21 +1,24 @@
-
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
- -DG_LOG_DOMAIN=\"cal-client\" \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DG_LOG_DOMAIN=\"cal-util\" \
-I$(srcdir) -I$(top_srcdir) \
+ -I$(srcdir)/calendar \
-I. \
-I.. \
-I$(top_builddir) \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
-lib_LTLIBRARIES = libcalutil.la
+lib_LTLIBRARIES = libcal-util.la
-libcalutil_la_SOURCES = \
+libcal_util_la_SOURCES = \
cal-util.c \
- cal-util.h \
calobj.c \
- calobj.h \
- timeutil.c \
- timeutil.h
+ timeutil.c
+libcal_utilincludedir = $(includedir)/evolution/cal-util
+
+libcal_utilinclude_HEADERS = \
+ cal-util.h \
+ calobj.h \
+ timeutil.h