aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/cal-util/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:07:51 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:07:51 +0800
commitbc61f8e11ccdb24c8a5ad4efafb31cfb097733fe (patch)
tree21301790bbead821c66310484253c57636936c1e /calendar/cal-util/Makefile.am
parent274026702024e9ff9ab593e263b662d37ab4316e (diff)
downloadgsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.gz
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.bz2
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.lz
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.xz
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.tar.zst
gsoc2013-evolution-bc61f8e11ccdb24c8a5ad4efafb31cfb097733fe.zip
Use EVOLUTION_GALVIEWSDIR.
* gui/gnome-cal.c (gnome_calendar_setup_view_menus): Use EVOLUTION_GALVIEWSDIR. * gui/e-tasks.c (e_tasks_setup_view_menus): Use EVOLUTION_GALVIEWSDIR. * cal-util/Makefile.am: Install libcal-util.la in $(privlibdir) instead of $(libdir). * gui/dialogs/comp-editor.c (setup_widgets): Get evolution-comp-editor.xml from EVOLUTION_UIDIR. (comp_editor_merge_ui): Get the file in EVOLUTION_UIDIR. * gui/tasks-control.c (tasks_control_activate): Get evolution-tasks.xml from EVOLUTION_UI_DIRECTORY. * gui/calendar-commands.c (calendar_control_activate): Get evolution-calendar.xml from EVOLUTION_UI_DIRECTORY. * pcs/Makefile.am (pcsincludedir): Version using $(BASE_VERSION). * importers/Makefile.am: Install evolution-calendar-importer in $(libexecdir)/evolution/$(BASE_VERSION). (sounddir): Remove. * gui/dialogs/Makefile.am (iconsdir): Version using $(BASE_VERSION). (gladedir): Likewise. (etspecdir): Likewise. * gui/Makefile.am (help_base): Remove. (install-data-local): Do not make the $(help_base)/C directory. (etspecdir): Version using $(BASE_VERSION). (gladedir): Likewise. (iconsdir): Likewise. (INCLUDES): Update the EVOLUTION_IMAGESDIR define to be versioned, and add a -DEVOLUTION_GALVIEWSDIR. * cal-util/Makefile.am: Install evolution-alarm-notify in $(libexecdir)/evolution/$(BASE_VERSION). * cal-util/Makefile.am (libcal_utilincludedir): Version using $(BASE_VERSION). * gui/alarm-notify/Makefile.am (iconsdir): Likewise. (gladedir): Likewise. * cal-client/Makefile.am: Install libcal-client.la in privlibdir instead of libdir. (libcal_clientincludedir): Version using $(BASE_VERSION). svn path=/trunk/; revision=19553
Diffstat (limited to 'calendar/cal-util/Makefile.am')
-rw-r--r--calendar/cal-util/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/calendar/cal-util/Makefile.am b/calendar/cal-util/Makefile.am
index 711f8d00d4..e739305661 100644
--- a/calendar/cal-util/Makefile.am
+++ b/calendar/cal-util/Makefile.am
@@ -16,8 +16,7 @@ INCLUDES = \
# cal util library
#
-lib_LTLIBRARIES = libcal-util.la
-privlib_LTLIBRARIES = libcal-util-static.la
+privlib_LTLIBRARIES = libcal-util-static.la libcal-util.la
libcal_util_la_SOURCES = \
cal-util-marshal.c \
@@ -27,7 +26,7 @@ libcal_util_la_SOURCES = \
cal-util.c \
timeutil.c
-libcal_utilincludedir = $(includedir)/evolution/cal-util
+libcal_utilincludedir = $(includedir)/evolution-$(BASE_VERSION)/cal-util
libcal_utilinclude_HEADERS = \
cal-component.h \