aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/cal-util/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-08-02 09:08:52 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-08-02 09:08:52 +0800
commit4e5b1da82e7ada3667bfa47471defd5932afc405 (patch)
treea5405dd760a6fee1ce6edc7f3935b3ab38e47b3d /calendar/cal-util/Makefile.am
parent3ce00eb40ede3898fda426b3e125139ab84242b4 (diff)
downloadgsoc2013-evolution-4e5b1da82e7ada3667bfa47471defd5932afc405.tar
gsoc2013-evolution-4e5b1da82e7ada3667bfa47471defd5932afc405.tar.gz
gsoc2013-evolution-4e5b1da82e7ada3667bfa47471defd5932afc405.tar.bz2
gsoc2013-evolution-4e5b1da82e7ada3667bfa47471defd5932afc405.tar.lz
gsoc2013-evolution-4e5b1da82e7ada3667bfa47471defd5932afc405.tar.xz
gsoc2013-evolution-4e5b1da82e7ada3667bfa47471defd5932afc405.tar.zst
gsoc2013-evolution-4e5b1da82e7ada3667bfa47471defd5932afc405.zip
Use CalComponent and the new property types instead of the old iCalObject
2000-07-31 Federico Mena Quintero <federico@helixcode.com> * cal-util/cal-recur.c (*): Use CalComponent and the new property types instead of the old iCalObject stuff. (cal_recur_generate_instances): Renamed from cal_object_generate_events(). Ensure that the component has the DTSTART property. (generate_instances_for_year): Renamed from cal_object_generate_events_for_year(). (cal_obj_expand_recurrence): Made static. (cal_recur_from_icalrecurrencetype): New function. We should really convert this whole file to use struct icalrecurrencetype instead. (cal_recur_free): New function. * cal-util/cal-recur.h (CalRecurType): Renamed from CalObjRecurType. (CalRecurrence): Renamed from CalObjRecurrence. * cal-util/timeutil.c (time_from_icaltimetype): New function. * cal-util/Makefile.am: Commented out the test-recur program. svn path=/trunk/; revision=4464
Diffstat (limited to 'calendar/cal-util/Makefile.am')
-rw-r--r--calendar/cal-util/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/calendar/cal-util/Makefile.am b/calendar/cal-util/Makefile.am
index 82da5a2564..2c95bcaec5 100644
--- a/calendar/cal-util/Makefile.am
+++ b/calendar/cal-util/Makefile.am
@@ -1,4 +1,5 @@
-noinst_PROGRAMS = test-recur icalendar-test
+noinst_PROGRAMS = icalendar-test
+#noinst_PROGRAMS = test-recur icalendar-test
INCLUDES = \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
@@ -62,11 +63,11 @@ icalendar_test_LDADD = \
# $(top_builddir)/calendar/cal-util/libcal-util.la \
-test_recur_SOURCES = \
- test-recur.c
-
-test_recur_LDADD = \
- libcal-util.la \
- $(top_builddir)/libversit/libversit.la \
- $(top_builddir)/libical/src/libical/libical.a \
- $(EXTRA_GNOME_LIBS)
+#test_recur_SOURCES = \
+# test-recur.c
+#
+#test_recur_LDADD = \
+# libcal-util.la \
+# $(top_builddir)/libversit/libversit.la \
+# $(top_builddir)/libical/src/libical/libical.a \
+# $(EXTRA_GNOME_LIBS)