aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/cal-util/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-06-07 05:56:20 +0800
committerSeth Alves <alves@src.gnome.org>2000-06-07 05:56:20 +0800
commitc219c79496fca669af1ae093a660a1ce4d81a682 (patch)
treef93a2842d0914f396b5a2872ed48536cbfec1f91 /calendar/cal-util/Makefile.am
parenta8b296282e5f93562c85b00b11d006b0eb7f1653 (diff)
downloadgsoc2013-evolution-c219c79496fca669af1ae093a660a1ce4d81a682.tar
gsoc2013-evolution-c219c79496fca669af1ae093a660a1ce4d81a682.tar.gz
gsoc2013-evolution-c219c79496fca669af1ae093a660a1ce4d81a682.tar.bz2
gsoc2013-evolution-c219c79496fca669af1ae093a660a1ce4d81a682.tar.lz
gsoc2013-evolution-c219c79496fca669af1ae093a660a1ce4d81a682.tar.xz
gsoc2013-evolution-c219c79496fca669af1ae093a660a1ce4d81a682.tar.zst
gsoc2013-evolution-c219c79496fca669af1ae093a660a1ce4d81a682.zip
fixed a bunch of problems use libical instead of libversit
* cal-util/icalendar.c, icalendar-save.c: fixed a bunch of problems * cal-util/calobj.c (ical_object_find_in_string): use libical instead of libversit (ical_object_to_string): same (dump_icalobject): prints the contents of an icalobject for debugging * gui/Makefile.am (LINK_FLAGS): link libical.a instead of libical.la so we don't have to modify the build system of the released libical * cal-client/Makefile.am (client_test_LDADD): same * cal-util/Makefile.am (icalendar_test_LDADD): same svn path=/trunk/; revision=3446
Diffstat (limited to 'calendar/cal-util/Makefile.am')
-rw-r--r--calendar/cal-util/Makefile.am25
1 files changed, 21 insertions, 4 deletions
diff --git a/calendar/cal-util/Makefile.am b/calendar/cal-util/Makefile.am
index d3517c2102..1bcab2b5ad 100644
--- a/calendar/cal-util/Makefile.am
+++ b/calendar/cal-util/Makefile.am
@@ -13,10 +13,14 @@ INCLUDES = \
lib_LTLIBRARIES = libcal-util.la
-libcal_util_la_SOURCES = \
- cal-recur.c \
- cal-util.c \
- calobj.c \
+libcal_util_la_SOURCES = \
+ cal-recur.c \
+ cal-util.c \
+ calobj.c \
+ icalendar.c \
+ icalendar.h \
+ icalendar-save.c \
+ icalendar-save.h \
timeutil.c
libcal_utilincludedir = $(includedir)/evolution/cal-util
@@ -27,6 +31,19 @@ libcal_utilinclude_HEADERS = \
calobj.h \
timeutil.h
+noinst_PROGRAMS = icalendar-test
+
+icalendar_test_SOURCES = \
+ icalendar-test.c \
+ icalendar.c \
+ icalendar-save.c
+
+icalendar_test_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/libical/src/libical/libical.a
+
+# $(top_builddir)/calendar/cal-util/libcal-util.la \
test_recur_SOURCES = \
test-recur.c