aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/cal-util/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-08-29 07:27:51 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-08-29 07:27:51 +0800
commit48ff93b64492c08d82e8452cb6b0e94b8582eb3e (patch)
treecc040d206fa875968c9753a18d510352295887c7 /calendar/cal-util/Makefile.am
parenta4789a176c9b256e018e31ac363ee9847da55500 (diff)
downloadgsoc2013-evolution-48ff93b64492c08d82e8452cb6b0e94b8582eb3e.tar
gsoc2013-evolution-48ff93b64492c08d82e8452cb6b0e94b8582eb3e.tar.gz
gsoc2013-evolution-48ff93b64492c08d82e8452cb6b0e94b8582eb3e.tar.bz2
gsoc2013-evolution-48ff93b64492c08d82e8452cb6b0e94b8582eb3e.tar.lz
gsoc2013-evolution-48ff93b64492c08d82e8452cb6b0e94b8582eb3e.tar.xz
gsoc2013-evolution-48ff93b64492c08d82e8452cb6b0e94b8582eb3e.tar.zst
gsoc2013-evolution-48ff93b64492c08d82e8452cb6b0e94b8582eb3e.zip
New function. We need this from code that dynamically updates from a
2000-08-28 Federico Mena Quintero <federico@helixcode.com> * cal-client/cal-client.c (cal_client_is_loaded): New function. We need this from code that dynamically updates from a client and could not have connected to the "cal_loaded" signal right after the client was created. * gui/calendar-model.c (load_objects): Do not try to load the objects if the client has not been loaded yet. (cal_loaded_cb): Check the status value. * gui/calendar-model.h (CalendarModel): Declare the private structure here so that gdb will give me love. * pcs/cal-factory.h (CalFactory): Likewise. * pcs/cal.h (Cal): Likewise. * cal-client/cal-listener.h (CalListener): Likewise. * cal-client/cal-client.h (CalClient): Likewise. * pcs/cal-backend.h (CalBackend): This no longer has a private structure, so remove it. * cal-util/Makefile.am (libcal_util_la_SOURCES): Removed the vCalendar and old iCalendar cruft. (libcal_utilinclude_HEADERS): Likewise. Removed the obsolete iCalendar test program. svn path=/trunk/; revision=5091
Diffstat (limited to 'calendar/cal-util/Makefile.am')
-rw-r--r--calendar/cal-util/Makefile.am26
1 files changed, 1 insertions, 25 deletions
diff --git a/calendar/cal-util/Makefile.am b/calendar/cal-util/Makefile.am
index 2c95bcaec5..d589e7d26b 100644
--- a/calendar/cal-util/Makefile.am
+++ b/calendar/cal-util/Makefile.am
@@ -1,5 +1,4 @@
-noinst_PROGRAMS = icalendar-test
-#noinst_PROGRAMS = test-recur icalendar-test
+#noinst_PROGRAMS = test-recur
INCLUDES = \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
@@ -23,11 +22,6 @@ libcal_util_la_SOURCES = \
cal-component.c \
cal-recur.c \
cal-util.c \
- calobj.c \
- icalendar.c \
- icalendar.h \
- icalendar-save.c \
- icalendar-save.h \
timeutil.c
libcal_utilincludedir = $(includedir)/evolution/cal-util
@@ -36,7 +30,6 @@ libcal_utilinclude_HEADERS = \
cal-component.h \
cal-recur.h \
cal-util.h \
- calobj.h \
timeutil.h
#
@@ -46,23 +39,6 @@ noinst_LTLIBRARIES = libcal-util-static.la
libcal_util_static_la_SOURCES = $(libcal_util_la_SOURCES)
libcal_util_static_la_LDFLAGS = --all-static
-
-#
-# test program
-#
-
-icalendar_test_SOURCES = \
- icalendar-test.c \
- icalendar.c \
- icalendar-save.c
-
-icalendar_test_LDADD = \
- $(EXTRA_GNOME_LIBS) \
- $(top_builddir)/libversit/libversit.la \
- $(top_builddir)/libical/src/libical/libical.a
-
-# $(top_builddir)/calendar/cal-util/libcal-util.la \
-
#test_recur_SOURCES = \
# test-recur.c
#