aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/cal-client/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2003-10-23 21:55:00 +0800
committerJP Rosevear <jpr@src.gnome.org>2003-10-23 21:55:00 +0800
commit5fa4b831a798a0aabfdbd46903dbed9b1bde7262 (patch)
treeb49306296b9610feaad3129024b52e71be90eee2 /calendar/cal-client/Makefile.am
parente047d6366a7a58e2bc05b1ba50b8c9b46d36febc (diff)
downloadgsoc2013-evolution-5fa4b831a798a0aabfdbd46903dbed9b1bde7262.tar
gsoc2013-evolution-5fa4b831a798a0aabfdbd46903dbed9b1bde7262.tar.gz
gsoc2013-evolution-5fa4b831a798a0aabfdbd46903dbed9b1bde7262.tar.bz2
gsoc2013-evolution-5fa4b831a798a0aabfdbd46903dbed9b1bde7262.tar.lz
gsoc2013-evolution-5fa4b831a798a0aabfdbd46903dbed9b1bde7262.tar.xz
gsoc2013-evolution-5fa4b831a798a0aabfdbd46903dbed9b1bde7262.tar.zst
gsoc2013-evolution-5fa4b831a798a0aabfdbd46903dbed9b1bde7262.zip
update g_date calls to non-deprecated calls
2003-10-23 JP Rosevear <jpr@ximian.com> * cal-util/cal-recur.c: update g_date calls to non-deprecated calls * cal-util/Makefile.am: turn off deprecated funcs * cal-client/Makefile.am: turn off deprecated funcs * cal-client/cal-client.c (cal_client_get_error_message): add OK message * pcs/cal-backend.[hc]: remove dead funcs * pcs/query.c: tidy headers svn path=/trunk/; revision=23035
Diffstat (limited to 'calendar/cal-client/Makefile.am')
-rw-r--r--calendar/cal-client/Makefile.am30
1 files changed, 16 insertions, 14 deletions
diff --git a/calendar/cal-client/Makefile.am b/calendar/cal-client/Makefile.am
index b8190fe5aa..9008c05940 100644
--- a/calendar/cal-client/Makefile.am
+++ b/calendar/cal-client/Makefile.am
@@ -1,6 +1,19 @@
-#
-# libcal-client
-#
+INCLUDES = \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DG_LOG_DOMAIN=\"cal-client\" \
+ -I$(top_srcdir)/calendar \
+ -I$(srcdir) -I$(top_srcdir) \
+ -I. \
+ -I.. \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/libical/src \
+ $(EVOLUTION_CALENDAR_CFLAGS)
+
+AM_CFLAGS = \
+ -DGTK_DISABLE_DEPRECATED=1 \
+ -DGDK_DISABLE_DEPRECATED=1 \
+ -DG_DISABLE_DEPRECATED=1 \
+ -DGNOME_DISABLE_DEPRECATED=1
CORBA_GENERATED_C = \
evolution-calendar-common.c \
@@ -20,17 +33,6 @@ $(CORBA_GENERATED_H): $(idls)
$(ORBIT_IDL) $(idl_flags) $(srcdir)/../idl/evolution-calendar.idl
$(CORBA_GENERATED_C): $(CORBA_GENERATED_H)
-INCLUDES = \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DG_LOG_DOMAIN=\"cal-client\" \
- -I$(top_srcdir)/calendar \
- -I$(srcdir) -I$(top_srcdir) \
- -I. \
- -I.. \
- -I$(top_builddir) \
- -I$(top_srcdir)/libical/src \
- $(EVOLUTION_CALENDAR_CFLAGS)
-
privlib_LTLIBRARIES = libcal-client.la
libcal_clientincludedir = $(privincludedir)/cal-client