aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/cal-client/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-03-02 06:31:11 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-03-02 06:31:11 +0800
commit3f2e2c06278e2c18938c62d31b719b0ba834383a (patch)
treee9f15c89fef951f7fe1f2ccf095019aef1523c97 /calendar/cal-client/Makefile.am
parentd164174a00f7712793a43ebbc29246901b28fd2c (diff)
downloadgsoc2013-evolution-3f2e2c06278e2c18938c62d31b719b0ba834383a.tar
gsoc2013-evolution-3f2e2c06278e2c18938c62d31b719b0ba834383a.tar.gz
gsoc2013-evolution-3f2e2c06278e2c18938c62d31b719b0ba834383a.tar.bz2
gsoc2013-evolution-3f2e2c06278e2c18938c62d31b719b0ba834383a.tar.lz
gsoc2013-evolution-3f2e2c06278e2c18938c62d31b719b0ba834383a.tar.xz
gsoc2013-evolution-3f2e2c06278e2c18938c62d31b719b0ba834383a.tar.zst
gsoc2013-evolution-3f2e2c06278e2c18938c62d31b719b0ba834383a.zip
At this point the calendar client and personal calendar server files were
2000-03-01 Federico Mena Quintero <federico@helixcode.com> At this point the calendar client and personal calendar server files were moved to the idl/, cal-client/, and pcs/ directories. * idl/Makefile.am: New file. * cal-client/Makefile.am: New file. Moved the libcal-client stuff from calendar/Makefile.am to here. * Makefile.am (SUBDIRS): Added the idl and cal-client directories. svn path=/trunk/; revision=2003
Diffstat (limited to 'calendar/cal-client/Makefile.am')
-rw-r--r--calendar/cal-client/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/calendar/cal-client/Makefile.am b/calendar/cal-client/Makefile.am
new file mode 100644
index 0000000000..fa9435d465
--- /dev/null
+++ b/calendar/cal-client/Makefile.am
@@ -0,0 +1,38 @@
+CORBA_GENERATED = \
+ evolution-calendar.h \
+ evolution-calendar-common.c \
+ evolution-calendar-skels.c \
+ evolution-calendar-stubs.c
+
+idls = \
+ $(srcdir)/../idl/evolution-calendar.idl
+
+idl_flags = `$(GNOME_CONFIG) --cflags idl`
+
+$(CORBA_GENERATED): $(idls)
+ $(ORBIT_IDL) $(idl_flags) $(srcdir)/../idl/evolution-calendar.idl
+
+INCLUDES = \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DG_LOG_DOMAIN=\"cal-client\" \
+ -I$(srcdir) -I$(top_srcdir) \
+ -I. \
+ -I.. \
+ -I$(top_builddir) \
+ -I$(includedir) \
+ $(GNOME_INCLUDEDIR)
+
+lib_LTLIBRARIES = libcal-client.la
+
+libcal_clientincludedir = $(includedir)/cal-client
+
+libcal_client_la_SOURCES = \
+ $(CORBA_GENERATED) \
+ cal-client.c \
+ cal-listener.c \
+ cal-listener.h \
+ cal-util.c
+
+libcal_clientinclude_HEADERS = \
+ cal-client.h \
+ cal-util.h